6TB drive lost power now shows as "No Media"


#1

Hoping someone can help me.

I had a power loss on my caddy which I use to run my WD Red 6.0 TB NAS drive externally. In other words, I was using the drive fine and when the power went out it just disappeared/stopped working. I guess it’s the same as not disconnecting it properly. All was fine until this point. Now the drive is no longer accessible.

Disk Management on Windows 10 shows: “Removable, No Media.” I’ve tried the various options I’ve been able to find online:
(1) change hard drive letter;
(2) uninstall/reinstall drivers for disk drives and universal serial bus controllers > USB Mass storage device.
(3) try drive on another computer.

None of those solutions worked. I would appreciate any tips or ideas which others may have to fix this.


#2

Hi,
You have tried all the basic solution to make your hard drive accessible but it not works. Please check if your hard drive is dead/damaged? A hard drive also stopped working due to damage in internal parts like head, platters, firmware etc…
If your hard drive is under warranty period, you can approach hard drive manufacturer. Else there is no option left except replacing the hard drive with new one.


#3

Drive is no longer under warranty. So that isn’t an option. Yes, I can always replace the drive, but that does not fix the initial problem. As I’ve had these power interruption problems on other drives, I’m looking for a possible solution. But in my other cases the drives showed up as RAW. This one doesn’t.

I have yet to try the drive on a different computer. That may provide a solution. But I’m wondering if this may be down to (1) the drive head not parking properly, or (2) if a surge of some kind caused an electrical fault. If anybody out there could shed light onto looking at these these possible causes, it would be helpful.


#4

Can you please check your USB port. It may be there is some issue with the USB port. You can check with USB 3.0 port as it has the better transfer rate.