500GB WD extertnal drive is not recognized

I use the drive many times… windows always recognize it.

I have used the drive with a usb on another PC and it worked (didn’t write anything to disk)

but when i tryed to connect it again to my PC or any other PC the drive is not recognized.

It presented the drive in a new letter (used to be E: Elements) now it’s F tried to change letter - id didn’t work. i don’t see the WD icon and i can’t get in to see the files.

error msg is:


I tried to use chkdsk also didn’t work:


on Mannage menu the drive marked as healthy but with no data:


i used WD lifeguard diagnostic which Passed.

What shall I do??


I recommend that you try formatting the drive, It seems that you have a case of data corruption. Note that formatting the drive will delete all data that you have stored on your drive.

If you need to recover the data on your drive, click on the link below for more information.


A raw drive is form corruption. Some software like EaseUS http://www.easeus.com/datarecoverywizard/recover-raw-drive.htm A last ditch effort that sometimes works is running the command prompt to convert a FAT32 partition to NTFS  works    . http://www.ehow.com/how_7656415_convert-raw-partition.html