500 MB My Passport suddenly not seen on my computer

Overnight I am unable to see My Passport on my computer, tried it on another computer and also unable to see it there.  I downloaded the LifeGuard Diagnostics tool and the Quick Test and Extended Test both show that there are no problems with the drive.  I am able to see the drive in Device Manager and Disk Management on the computer.  All of the steps above were taken after doing research on the WD support site on what to do but now I am at a loss on how to proceed.  At this point the most important outcome is being able to retrieve the files on the drive.  I would be most appreciative if someone could give me the best way to proceed. 

This is a new Dell, I have had it for about a month, Windows 8 and haven’t had any problems with the drive until yesterday. 

Thank you! 

What OS and what does Disk Management say about the drive raw unallocated? 


I am a bit confused, the model and serial number that appear in the diagnostic information are not the same as what is on the back of the hard drive so now I don’t even know if the information I am seeing is relevant to the My Passport.  At the bottom right of the computer in the task bar there is an Intel Rapid Storage Technology icon and the model and serial number that appears in the Data Lifeguard Physical Drive are the same as what displays in the Intel Rapid Storage Technology icon.  I don’t know if these are the same thing?  My Passport P/N is WDBACX0010BBK-01 and the Model number in the Data Lifeguard Physical Drive is WDC WD5000AAKX-75U6AA0 so now I am not even sure if the Data Lifeguard tool is seeing the My Passport or something internal to the computer? 

The OS is Windows 8.1.  I am not sure how to answer the other question until I am sure that what I am seeing in Disk Management is the My Passport. 

With the My Passport disconnected from the computer when I run the Data Lifeguard tool it is seeing the model number WDC WD5000AAKX-75U6AA0 hardware and performing the Quick SMART Test and passing so now I don’t even think it is seeing the My Passport.  

About 30 minutes ago I was at the computer and saw the My Passport connected on the My Computer screen and was able to open folders and access files, everything looked fine, and than it just disappeared again.

could this be a cable issue?  When I researched the PN this is actually a 1TB My Passport Essential.

It’s possible that it could be a cable issue. Make sure the cable is not longer than the original and don’t use a hub to connect.