500 GB Passport Essential - "Backup" Tab Grayed Out after Firmware Upgrade


#1

HELLLPPP!!! My 500 GB Passport external hards drive had been working just fine, when I got a message to upgrade the firmare to b. 1.4.5.2. I updated Windows .NET to v.4 as I believe I was supposed to, and applied the first software fix, then the second, as instructed to by WD’s website.

I’ve rebooted my PC several times, but each time I access my WD software I am unable to access the BACKUP tab. It is grayed out.  I even tried reinstalling WD Firmware .1.4.5.2, but to no avail. Needless to say, I am *really* annoyed by all this, since the danmed thing was working FLAWLESSLY before the stupid  so-called “upgrade”.


#2

Hi there, do you still have the older installation file on your VCD or inside the drive to try it out?


#3

Have you tried to reinstall  the WD Smartware? 

Uninstall the WD Smartware, then restart your computer; after you restart your computer, install the latest version of the WD Smartware. Make sure that you restart the computer before reinstalling the software.

Hope it helps.