50 MB/s - yet PC to PC is 100+ MB/s - does link aggregation work?

I’ve read a couple of threads regarding poor performance for the EX4. 50 MB/s does seem slow and I’m pretty sure that’s not a limit of my 1000 Gbps network (Linksys Switch - all Cat6 all 1000 ports).

So to test:

  1. PC to EX4 = 50MB/s
  2. PC to PC = 100MB/s
  3. PC to USB 3.0 drive = 150+ MB/s

I read the two or so threads about setting the EX4 into link aggregate mode which means I’ll need to setup my switch into one of the support link aggregate modes AND setup each PC (that has two 1000 Gbps ports) to link aggregate via OS.

So after doing all this, I’m at about 52MB/s on average. So my assumption is that the bottleneck for the EX4 is in it’s internal CPU/RAM and link aggregation just doesn’t improve performance to any significant degree.

Has anyone else been able to exceed about 52MB/s write speed on the EX4 (RAID 5)?

Thanks, Rob.

Hi there,

I have not tried link aggregation, but i have transferred within my network and have achieved more or less at 67 MB/s on some points it can drop to 50’s i believe this depends on the types of files that are being transferred. Lets see if another use can share some information or tips on this matter.

Thanks for the response.

50 MB/s is usually my best case for larger files, drops to 10-15 MB/s for smaller files.

After reading more, it looks like the issue appears to be with the EX4 CPU/RAM limitations … I was reading up on WD EX4100 diskless and the CPU/RAM are better than what comes with the EX4 diskless with speeds closer to 100 MB/s. Cost difference is about $100 more for the EX4100.

So the one question you might be able to answer for me … if I move my 4 3TB WD drives (RAID 5) from my EX4 to a new EX4100 would I loss all the data on my drives or would the EX4100 be able to work with the same RAID 5 array?

Thanks, Rob.

There is a feature called raid roaming. I have not had the chance to try t but if you setup a RAID array and move the drives on the same order, the volume can re appear but as i said i have not tried it