4TB Passport recognised by Windows 10 but fails to load

Hi, I’m sure this has been discussed before but I can’t find them.

Hadn’t used the Passport for a few months. Plugged it into the blue USB as usual. The loading light started flashing and it showed in the list of drives (I have 6 internal) but when clicked on, Windows explorer hangs.

In disk management it shows as well and says it’s working. When I’ve tried to go into safe mode with it plug in, it blocks. When I remove it everything is fine.

Stumped and hope someone can help. It’s about 2/3 years old.

Cheers, John

Hi @johnrxx99,

Please refer to the below link to troubleshoot the issue:

Title: Windows or macOS Cannot Find My Drive
Link: Windows or macOS Cannot Find My Drive

Please test health of your drive using Western Digital Drive utility:

Title: Setting up and using WD Drive Utilities
Link: Setting up and using WD Security and WD Drive Utilities

Hope it helps!!

Thanks for the reply but nothing worked. I guess the drive has failed.

Hi @johnrxx99,

Please refer below link to check with respective team to know possible replacement process:
https://support-en.wd.com/app/utils/login_form