4TB My Cloud disappeared- Fast blinking blue light! HELP

Hi, I had the same issue. The problem is with the FW version 2.31.174 (Released Mar 26th).

Thanks to the gentleman / woman who had posted the following steps, i was able to recover my WD NAS. Follow the listed steps.

  1. Download these files:
    The product support site only gives you the latest (but faulty FW). Don’t pick this. Pick the FW from:

https://ftp.anionix.ru/WDMyCloud/WDMyCloud-Gen2/ (Version 2.30.193). Store it in your laptop.

https://ftp.anionix.ru/WDMyCloud/WDMyCloud-Gen2/usbrecovery.tar.gz (WD Recovery + My miniOS)

  1. Use any USB Flash drive, format it to FAT32 (Important!)
  2. Unpack usbrecovery.tar.gz to this drive (You will get “boot” folder and 4 files inside)
  3. Plug this USB drive to WD MyCloud, turn on power. Wait yellow-red (blinking) light.
  4. Connect via Telnet (Search IP in your router, unde DHCP section.)

This is a trial and error situation to find the right IP. If you router shows you the list of attached devices, try all the wired connections. Use the PuTTY tool for telnet.

  1. Install original WD recovery and reboot:
    Type each of these commands over the Telnet connection.

mkdir -p /mnt/usb /mnt/root
mount /dev/sda3 /mnt/root
mount /dev/sdb1 /mnt/usb
cp -r /mnt/usb/boot /mnt/root/
cd /mnt/root/boot
rm uImage uRamdisk
mv uImage-wdrecovery uImage
mv uRamdisk-wdrecovery uRamdisk
cd /
umount /mnt/root /mnt/usb
sync
reboot -f

  1. After reboot device get old IP address and accessible via Web-GUI (Recovery mode). Use original firmware (.bin file) here (2.30.193).

Done!

  1. If you wish to not run into the same trouble again, remember to turn the auto FW update off.

The front LED is still blinking blue. What puzzled me was the amber light on the ethernet port. still ON even though I unplugged the cable.

As of friday night, after doing the 40 seconds reset. I left the drive rebuilding (or so I hope), and I decided to let it take until monday night, before trying something else (what, I don’t now - maybe open the case, unpluging and pluging back everything, hoping for the best?? :slightly_frowning_face:)

Ok, this is fresh info.
What scares me is…If I do this, I’m LOOKING FOR (in puropose) for a "yellow-red (blinking) light."?
I Thought those were BAD.
Then… the current situation is that, while the blue light is blinking/fast flashing, I DO NOT see the drive on my network (i used a different router, just connecting the drive and my notebook via ethernet, then using an IP scanner)
So… if I do this, you’re telling me that after booting via the usb flashdrive I will find the drive on my network?
Then…let’s say I find it. to what port do i connect via telnet, 80? 21? I don’t specify port?

One last IMPORTANT question. do I lose all my data?

Thx

Sebsa

You still didn’t say if the led changed color when you pulled the Ethernet cable.

The front led always flashing blue. The ether net led port light. Remained amber AFTER pulling the chord.

That’s no the case anymore though, onnfifsy night I fifi the 40 seconds reset with the drive unconnected, so, obviously, no lights on the back.

48hs ñater

Stiññ flashing blue on the front. I hear disk acticlvity. Should I still wait? Or am I losing time? What else could I do?

Let me explain the recovery method. Since the WD NAS is bricked, you have to boot it with a USB stick that contains the boot (read recovery) image (uImage - Linux Kernel & uRamDisk - Filesystem). The preparation of the USB boot disk involves the above.

Once you insert the USB boot drive and power on (insert & then power on), the flashing blue light would stop and turn to yellow-red blinking. This means WD has booted up with the recovery image. The recovery image contains a minimal DHCP client that gets an IP Address from the Router. Mind you, this may not be the same IP address WD was getting during its working days.

There are 2 ways to get this IP address. Method 1 - Login to your RT. Go to LAN settings / menu. Search for attached devices. One of the IP addresses must correspond to WD. Usually there is an IP Address + MAC Address mapping in this list. I noticed, the MAC address wasn’t coming right. This is a trial and error part.

Method 2 - Netscan should also give you the same info as the router.

Now, to the Telnet part. Install PuTTY. A very simple low footprint tool. When you launch it, it provides different connection options. Default, i suppose is SSH. Select the Telnet button. Port number will default to 23. Enter the IP address and connect. You get the WD shell from where you need to type the listed commands.

The recovery image runs a minimal web server. So when WD reboots with recovery image, it comes up back with the original IP address and can be accessed through the web. Note, when WD restarts, remember to pull out the USB stick. Otherwise, it will again boot with the USB disk, not the recovery image.

No, you won’t lose any data. This was possibly an untested FW that screwed up all the devices. After I recovered my NAS, I loaded the newest image again to test. It got to that bricking stage again.

The links you provide to anionix.ru no longer work. That domain seems to have been abandoned.

Does anybody know where to find these files?

See the following link which is an alternate to the anionix.ru site.
https://drive.google.com/drive/folders/0B_6OlQ_H0PxVRXllYjY5RG1CZEU

Direct link to the usbrecovery.tar.gz file: https://drive.google.com/open?id=0B_6OlQ_H0PxVUWdCU01DcTdMWk0

Thanks a lot for the info, Now I understand the process and I’m not afraid to an upcoming yellow/red light.

I do have a couple of questions

  1. Am I wasting time, by leaving the drive on watching the blue blinking light? (I performed the 40 seconds reset on FRIDAY NIGHT Thats almost 60 hours by now) - I left the drive NOT CONNECTED TO ANYTHING (no ehternet)

  2. Under normal circumstances. would the drive come to a steady blue light with NO Ethernet cable connected to it?

  3. On the post where the firmware was mentioned, I was recommended to download a previous FW version, unfortunately to a domain that is no longer active… so, I ALREADY downloaded the BOOT software from the other new link provided… but as far as the firmware goes. …

https://ftp.anionix.ru/WDMyCloud/WDMyCloud-Gen2/ (Version 2.30.193).

If the current fw on my drive is corrupted (this is what people are saying caused the problem). So, do I NEED to download a FW version from somewhere or during this boot process the corrupted fw will be overwritten, that is… I should forget about the firmware?

If NOT, and I DO neet to download a firmware, not the latest, (Firmware Release 2.31.174 (03/26/2019) ) the only providaded by WD, any help finding this previous FW version (Version 2.30.193)?

  1. And Finally, this one is important. What’s the average time for this process to complete?. Am I looking at days, hours or minutes?

Thanks ALL for your help. I’m still hopeful of getting NAS back :slightly_smiling_face:

The following Google Drive link is a mirror of the anionix.ru link (hosted by the same person)
https://drive.google.com/drive/folders/0B_6OlQ_H0PxVRXllYjY5RG1CZEU

One can download earlier firmware for their single bay/single drive My Cloud model from the following link:

THANKS FOR YOUR CONTINUOUS HELP!

Mine is a Gen2 Mycloud 4Tb, which fw do you recomend I download? Because, previous to this, the auto firmware update feature was ON, so, I would assume that previous versions to the one of march 26, were applied succesfully and the recomendation was using 2.30.193 (5/8/18)

So, should I go for 2.31.163 (1/8/19)? or 2.30.193?

2.31.174 (03/26/2019): http://download.wdc.com/nas/My_Cloud_GLCR_2.31.174.bin
2.31.163 (01/08/2019): http://download.wdc.com/nas/My_Cloud_GLCR_2.31.163.bin
2.31.149 (10/18/2018): http://download.wdc.com/nas/My_Cloud_GLCR_2.31.149.bin
2.30.196 (09/21/2018): http://download.wdc.com/nas/My_Cloud_GLCR_2.30.196.bin
2.30.193 (05/08/2018): http://download.wdc.com/nas/My_Cloud_GLCR_2.30.193.bin

  1. Yes, you are wasting time with those 4 and 40 secs resets. Nothing will happen.
  2. No, lack of Ethernet connectivity (under regular operation) will show up in the LED. Don’t fret about the Ethernet cable and its LEDs for this issue.
  3. Take 2.31.163 (01/08/2019): http://download.wdc.com/nas/My_Cloud_GLCR_2.31.163.bin . The last stable one.
  4. 15 minutes is all it takes to recover.

OK. I’ll proceed tonight, then… fingers crossed :crossed_fingers:

Thanks everyone!.

I’ll keep you updated on the drive status

Hi,

I have the same issue.

I tried to boot with the USB stick with the folder “boot” inside. But the led is still blinking blue (fast).

:confused:

I have the same problem as you. I did get a red/yellow light using a USB stick with the recovery tool (starts flashing blue, takes 2-3 minutes to get to red/yellow), but the device didn’t get an IP so I couldn’t do anything. So don’t get your hopes up. Time to open up the case and see if I can copy the files somewhere else.

Are you sure? When I tried to boot from a recovery USB. Even though my router has reserved an IP address for my device. The recovery USB ended up with a different IP address. In my
case .247. So check with your router to see what address it assigned to the My Cloud.

Update:

A LITTLE progress, but no success (yet). Still need help

I used the pendrive - Amber/red Flashing light
Found the IP address on the router - One curious data, the MAC Address does not match the one on the bottom of the drive - (the one reserved on the router)

I downloaded and installed PuTTY (0.71) - I double clicked on putty.exe, On Session field, I completed the IP Address and changed to port 23 (by default was 22). New window opened, and stayed there a green block cursor, could not write, or do anything.
So I closed the window. I tried using the command line: psftp (ENTER) open IPA.DDR.ESS.xxx 23 and I get : FATAL ERROR: Incoming packet was garbled on decryption

Anybody can help me how to pass this?

Latest Update…

First, once again, I am puzzled by the fact that the MAC Address that I found, was different that the one i have registered for the drive (which is also the one the label) booting from a pendrive should NOT change this…should it?

Anyway, moving on.

No luck with PuTTY, finally I connected using Windows Telnet client and i got a prompt /#

I wrote and enter all the commands always ending with a prompt back…
Except when I entered umount /mnt/root /mnt/usb

I did not get a prompt back, just the cursor.
Minutes went by, I started typing, but nothing really happened.
After an hour or so…, I closed the window, unpluged the drive and plugged it back on

To my (sad) surprise the drive started with a blinking blue light, and after about 30 seconds, it changed into a red blinking light…

I finally got to how PuTTY worked, (I was using as SSH when I was supposed to used TELNET), anyway, tried the same procedure with PuTTY and with a couple of telnet clients, but I always get to the unmount command then nothing… last time, I left it there, writing NOTHING after the umount command and hitting ENTER, for 8 hours. Still nothing happened. Still blinking red light when it turns on without the pendrive

What happens on the umount command? - I’m no unix user, i read about the command, but i just don’t know why I don’t get ANY response from it… is there any way of knowing what`s going on?

Better yet, any alternative procedure?

PS: The drive seemed to be working (reading/writing noises) all through the night (it was on my bedside table)

Unmount will hang if you didn’t execute the “cd /” command before. I trust you did that. Just to eliminate that possibility. Try to format the USB drive (to FAT32), copy the files again. To eliminate any errors on the USB drive.

Since you are stuck anyway, you may try without the umount command. There is a “sync” command before the reboot. Try that and reboot. During reboot the unmount happens automatically. The unmount and sync are to ensure the copied files are properly done.

On the RED blinking light, there is a thread. The red light keeps blinking. Including the Ethernet connection not being proper…