4T WD RED WD40EFRX 2 failed disks displaying 0 storage

Hi all

I have one of my NAS systems that has 4 WD RED drives on RAID5.
Out of the blue, two of the disks were no longer read by the NAS unit.
I have tried checking the disks on Linux and Windows, but I am unable to run SMART tools on either of these 2 failed disks, even with the Data Lifeguard Diagnostic for Windows, they just display 0 capacity and no SMART status available.
I am not sure what else to try. I need to recover at least one of the disks so I can recover my data.

Any ideas?

Thanks

M

if you have Synology NAS you can find many useful guides for such troubles in our independent Synoforum.com.
You can start here

Thanks jeyare. However my NAS system is Netgear. The faulty disks are not seen by the NAS or any other system.

doesn’t matter what kind of NAS you have, there is a way, how to check the disk drive from Linux directly, or from LiveCD. you can use the thread mentioned in my link above

Thanks for the links jeyare.

I am still baffle by the fact that after seeing high IO on my NAS and restarting it, disks 3 and 4 were no longer recognised by the NAS enclosure or anything else.

I have already tried smartctlools and mdadm but the disks cannot be read so I cannot do much.
I cannot check or mount the disks as they are not recognised when connected.
The serial numbers or their storage capabilities are not displayed by smartctlools, so trying to rebuild the RAID,even with just 3 drives does not seem an option.

When running the Data LifeGuard Diagnostic utility from WD the disks serial number or capacity is not shown and any test run on them comes back without errors in a matter of 1 or 2 seconds so its not reading them.

I even tried cloning the drives with the WD offered Acronis software but this failed as the software does not see the disks as WD ones. I can use it with the other 2 disks.
I did also try cloning the drive with Clonezilla but I had the same issue.

I don’t know what else to do :frowning: