403 Forbidden error when using WebDAV

I have set up an EX2 with the latest firmware update, java etc. I have enabled FTP, WebDAV, and SSH and given then user access.  I have forwarded ports for WebDAV (4443 and 8080) and yet when I try to connect to the MyCoud, I get a 403 Forbidden error.  This happens even if all I am trying to do is access the drive across my immediate network (same subnet).  If I try the 4443 port ( https://192.168.xx.xx:4443/Public)) I get the unsigned certificate message and a login screen before seeing the 403 error.  In other words, my browser finds the drive, but the drive is actively rejecting the connection.  If I try this from a MAC, I can connect using the 8080 port, but I get a “problem with server” error on the 4443 port.

It seems as if this is a basic functionality associated with WebDAV.  Am I missing something?  Does it work on a MyCloud Ex2?

Thanks for any help you can give me.  Right now, this thing is a paper weight because I cannot use the WD application to access the device remotely.  I have gotten FTP to work, but it seems dubious to use FTP for backing up across the internet.

See this post -> http://community.wd.com/t5/WD-My-Cloud-EX2/Secure-WEBDAV/m-p/766133#M792

thank you.  I had seen that post, but not quite made sense of it.  Skipping Windows explorer altogether, I was able to map a network drive to the internal IP address (once, but then not the second time I tried the same thing).  It seems that something about webDAV or Windows or the WD implementaion is a bit unreliable.

As with I believe many, my main goal here is to set up a remote back-up server that I access continuously to mirror drives.  I have been focussed on trying to get a secure pipeline, though I have no intention of connecting to this device wirelessly.  I will be connecting two homes together. Do you have any thoughts/suggestions about approaches?  I have good backup software that will work transparently if I can give it a network path or share address.  It even supports WebDAV, SSH, secure FTP, etc.  Trouble is that it sees the same 403 Forbidden errror that I see with Explorer.

Should I try Netdrive (in spite of their very recent WebDAV problems)?  Is encryption really that important for pipelines that are never accessed on public networks?  I could encrypt my drives before syncing, but have had one failed certificate that rendered a director unreadable on a new machine…

Thanks again for any thoughts you might have!

Sorry, I’m not very familiar with WebDAV (except just how it works), so I can’t offer anything more. Perhaps other forum users with more WebDAV expertise can chime in. I am also not familiar with Netdrive.

I realized a long time ago that not only was FTP on EX2 broken but that EX2 didn’t come with SFTP. The only way to get SFTP on EX2 is to build your own firmware using WD’s firmware source code. Doing so isn’t what I’d recommend as it may void your warranty and also isn’t easy. I did post some ideas on how to implement SFTP in EX2’s firmware in another thread, that you can search for.

BTW, I had played with iSCSI on the EX2 and it’s pretty neat…but I really don’t know if it does the operations over an encrypted pipe or not (most likely not).

And to your question, if encryption is really that important for pipes that are never accessed on public networks, I’m not sure what you meant by “never accessed on public networks”. If you are talking of using the Internet, then I’m not quite clear why you say the pipeline is not accessed over public network. Any unencrypted communication between two remote computers over the Internet is not secure. Now it’s up to you whether you feel your info doesn’t warrant encryption. If you feel comfy with the potential of having your data being looked at by a third party , then there is no need for encryption…if you don’t feel comfy, then there is a need.

teleRoy - In case you don’t see the other post, thought I’d post here to let you known Vertech1 was able to resolve his WebDAV issues with https using Windows’ in-built WebDAV client, after he applied a small change mentioned in a link that I posted there. Please see that post -> http://community.wd.com/t5/WD-My-Cloud-EX2/Secure-WEBDAV/m-p/769633#M848

And if that post fixes your WebDAV issue as well, then please click the star under my username on the left (preferably on THAT post and not this one) to give me a kudo.