401 Error Code When Sharing Links To Files

Hey Everyone I am having an issue where I get an error message when sending a link to a file.  It used to automatically download the file but now I get this:




<error_message>Request is not allowed</error_message>

Has anybody had experience with this issue?

Thanks in advance!

Welcome to the Community.

What have you tried to far? And which firmware revision do you use?


The firmware currently on the device is v04.04.00-308.  I have tried a system only restore but no luck.  I have found other threads that mention adding either 8080 or 80 after the WDMyCloud.com in the links that are shared and it has worked, but I want to know why this is happening now and how I can go back to the links being correct when shared.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support



Works for me.


If you’ve updated your devices and apps to OS 3, the “Sharing of file” links back to files.mycloud.com


My Cloud 4.04.00-308

My Cloud App 4.4.0 - iPhone 5s

  • Share Link from iPhone App
  • Picture is in a Private Share

Here’s the link to my (recently sold boat) on Web Files


If you’re not on OS 3, then more information about your setup will be needed by support to assist.