400GB of data disappeared - "Share function failed" error


I have been very patient on this journey with WD My Cloud 2TB  from December, learning and handling all the quirks of this product, its slowness, access problems on my mac, never-ending indexing of media, privileges not working, remote access not working etc. I have coped with most of those somehow and there was even a transient moment when I was relatively happy to be able to access my centralized files on my wifi and remotely. But now its over for me. My cloud has just lost 400GB of my data, which means it has failed me on the single most important criterion: safety of my data.

Here is what happened:

I added a new user for whom I granted remote access. Then, tried to switch off Public Access to configure privileges for my main multimedia share which resulted in “Share function failed (400099)” error and disappearance of the majority of the content, around 400GB of videos. The high level structure of this share seems intact, that is I can still see my Music, Photos, Videos etc and music and photos seem intact at the first glance. In Videos folder, however, some of the subfolders and files are there but most of its content (=hundreds of folders and files) are gone. The dashboard now says 1.5TB free capacity whereas it was 1.1TB before the error occurred.

How can I check if the content is deleted from the drive or is it only that my cloud cannot see this content anymore?

I’ve checked that there is the same folder structure with missing content when I connect from my mac via SMB protocol, from my Windows machine and when I ssh into the drive. AFP protocol on mac doesn’t see that share at all.

Also “Share function failed” error shows up every time I try to switch off Public Access on this share and the share stays Public.

EDIT: Since I created a new user and tried to modify share permissions, could my problem be related to SMB permissions bug? If yes, should I fix my SMB configuration as described in the linked thread?

I’m on v03.04.01-219 firmware.

Thanks in advance. 

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support