4 TB Drive Unrecognized

I’m a new owever of the Live SMP, and posted a few days ago about how to format my 4 TB drive before connecting it too my player

Here’s that post - http://community.wd.com/t5/WD-TV-Live-SMP-Discussions/4TB-Drive-Formatting/td-p/621223

To pick up where this left off, I decided to format the drive again using non-journaled, and proceeded to copy a few gigabytes of media over with no problem.

However, when I plug the drive into either of the USB ports, the player does not recognize that it’s connected.

I’ve searched these forms for people who might have had simlar problems, but havne’t been able to turn up any real conculsive answers as to why this might be happening, or what it is that I might be able to do to resolve the problem.

Does anyone have any thoughts or suggestions that may help?


The WD TV Live SMP supports 4TB drives and this drive should work without any issues. Make sure the Media player has the latest firmware installed and also make sure the drive is plugged into a wall outlet in order to discard a power issue.


1 Like


Thanks for your response.

The drive is indeed plugged into a wall unit, and the player is updated with the most recent firmware. However, it is still not being recognized.

As I mentioned, it is recognized when plugged into my Macbook Pro.

Are you able to show me any documentation that shows that the WD TV Live SMP does indeed support 4 TB drives?

In searching through these forums, It does seem that there are quite a few posts from people who have problems with drives that are 3TB-4TB in size, but also that there a few people who have had success.

Is it that hit and miss? If so, which drives of 3TB or 4TB size are officially supported?

 Hi, I am using a 4TB Seagate Expansion on my WDTV  Live SMP, connected at the rear USB Port pf the SMP and with the latest firmware and so far no problem.  Try to plug it in the front or the back usb port and see which works. 

1 Like


So I believe the problem laid with my patience. I left the drive plugged in for 10 mins or so, and eventually the player connected to it.

However, the light has been blinking for approximatly 36 hours while the player builds the library. There’s approximatly 2.7GB’s of media on the drive, so I’m happy to allow it to continue, if this is what’s needed in order to play the content.

That said, is it normal for it to take this long?

If only 2.7GB of media, it should not take that long, Iam assuming you meant to say 2.7TB, it would take long to compile specially if you have turned on the media library on,

1 Like

Sorry, I meant 2.7TB.

I do have the media library turned on, so I will continue to wait for the process to finish, but Is it normal for it to take days for it to compile this much data?

“Compiling”, no.   “Getting Content Info” – perhaps.

If it’s stuck on Compiling, it probably came across a file that it tried to compile and it wrecked the compile process.

1 Like

At the top of the main menu, there is a white bar that says “Compiling Media Library” with three dots that go back and forth.

Is there any way to deterimine if it’s actually stuck, or stil in the process of compiling? I would hate to stop it at this point, only to have to do it all over again…