3TB WD My Book Essential + BSOD = corrupted drive?


My computer has a buggy WIFI driver and while I was transferring data to my NAS I received a BSOD. My NAS is fine but my 3TB WD My Book Essential (WDBACW0030HBK-01) became inoperable. Windows 7 stopped recognizing the USB connection (I tried reinstalling the USB dirvers but got “The device could not be installed correctly”), I tried it on another computer running Vista with the same result.

I popped out the drive and used a USB/eSata combo unit to confirm that the disk appears as 746GB unallocated space. I know better than re-initializing it so I’ve been searching for the appropiate file recovery software. Man, am I confused. So, I’m guessing I need a software that supports GPIT formatting, but then I find out that WD allocates it in larger(?) chunks, and yes, I think it has smartware.

I tried using the Data Lifeguard Diagnostics tool and I got excited as it recongnized the drvie as 3TB but it fails with a “Quick Test: Read Verify Sector Ext” error. NOTE: This test was done using the eSata adapter because the enclosure is not recognized.

Where do I go from here?

OK, my opening post was a bit too open-ended. I apologise; I was tired, frustrated, and largely discouraged.

Some more testing and I think it’s actually the circuit board that went bad. In hindsight the drive was slow to connect to Windows and sometimes I had to unplug/re-plug the USB connection to get it to work, but I still think it was a WIFI drvier that caused the BSOD.

I was trying to go through my options as follows:

  • send the drive to be repaired by a WD authorized shop > probably about $80 and they might charge me for parts

  • buy a duplicate new/used enclosure (about $100-140), void the warranty, pop my old drive in, copy everything onto a non-WD drive and chuck the enclosure in the trash. I’d have my old 3TB and a new one, so although it’s potentially more money, I’d still get a new drive.

In the end I have decided to buy a replacement unit and swap my old drive into it. If I need to do data recovery, that’s fine, my main issue was the SmartWare encryption preventing me from doing so.

I ordered the same unit on ebay (new in open box) and I was able to open the enclosure and swap the USB controller/encryption board. All my data is intact.

For those of you with a similar issue, opening the case and controller removal/replacement is shown here. (I am not endorising the company that made the vid. As I said, I purchased a whole unit on ebay).


Keep in mind that opening the drive voids the warranty. You might be able to obtain a circuit board here  https://wdc.custhelp.com/app/answers/detail/a_id/70/session/L3RpbWUvMTM5MDMyNjIwNS9zaWQvZVBrTU9YS2w%3D or off Ebay.