3TB MyBookLive is taking a long time accessing the files located on it?

This has just been happening in the past couple of weeks. I’ve updated to the latest firmware and it still does it. I just timed it when it was access a folder with about 30 photos on it and it took 106 seconds to fully open. 

Is this normal because I don’t remember it taking this long. 

I have had it unplugged for a week or so, if that has anything do with it. But it’s been plugged in for several hours now. 


how do you have it connected to your network?  how are you trying to access it?  I do know that on some networks the my book live can have problems resolving its dns.  which means that if you’re trying to access it using the drive name, then it might have problems connecting.  have you tried downloading wd link to see if that helps set up a better connection? it connects by the ip address.

Is it possible the drive was in standby (sleeping) at the time you went to access the files - and required time to fully spin up before showing you the files?  Does this happen on every folder or just folders containing photos?

I have it connected DIRECTLY to my router. I was accessing it by the PUBLIC folder that sits on my desktop. 

I wasn’t sure of any other ways to access the files than the PUBLIC icon. 

I know you can go into the SETTINGS by the WD QUICK VIEW or whatever it is. 

I have the power saving feature turned off, meaning that it nevers goes to sleep.

It does happen with every folder and any folder. 

It seems like it even takes a long time to access the feature settings in the WD LIVE DASHBOARD. 

Oh, and the drive seems like it’s constantly running/spinng as I can hear it sitting on my desktop. Is this normal?

I have Time Machine turned off because I was wondering why it was being so slow and I didn’t want anything running or access it while I was trying to figure it out. 

I did a quick test with the MBL in standby.  It took about 15 seconds to connect to the drive - 10 second to navigate to a folder containing pictures and 10 seconds to open the first photo selected.  On subsequent access (after dismounting the share and with the MBL not sleeping) - the same steps toook about 18 seconds - with the majority of the delay being in navigation to the subfolder  - my slowness - not necessarily the drive’s  slowness.  In this case - the test was done on a Mac - via ethernet (not wireless).

Performed same steps using a wireless connection - and no notable difference in timing.  Your 106 seconds seems a bit on the slow side - but more information on what exactly what you were doing and how you were doing it - woul be helpful.


Just to something to let you know as far as it being slow…

I just deleted a folder with 3 photos inside of it, it took about 3 minutes to delete it. 

quickview is not the best way to access it.  download wd link and install it.  you may be having problems resolving the dns.  that would account for the slowness and intermittent connection.  wd link should fix that if that’s the case.

If you have standby disabled the drive will spin constantly.  If you are not accessing the drive - do you notice the LED on the front blinking green even when you are not transferring data to or from the drive?  If so - it is possible that you have the Twonky media server enabled and it may be trying to index the files in the public share.  If you recently copied a large number of files into the public share - and Twonky is enabled - Twonky will try to process those files and may take quite a bit of time to do so.  If nothing is accessing the drive - you should only hear the drive spinning - the LED on the front should be solid green (for the most part).  If something is accessing the disk - you will definitely hear the read/write heads clicking back and forth as the drive is accessed. 

I just copied a folder with 100 photos - it took about 20 seconds - and 4 seconds to delete the folder.  You go into dashboard and go into settings and click on the media tab - and check to make sure that both Twonky and the iTunes server are disabled - to factor out any of these items causing your slowness.

A couple of answers for you…

  1. I have the standby disabled.

  2. The front light is constantly blinking even though I’m not transferring anything to the drive. 

  3. I don’t have Twonky enabled at all because I don’t know what it is and how I can use it on my Mac. 

It doesn’t appear the WD LINK is available for the Mac. I just tried downloading it and it was an executable file. 

I went and disabled the iTunes server but the Twonky service was already disabled. 

Is remote access disabled as well?  I believe there is a background job that will search for photos in the public/Shared Pictures and public/Shared Videos folders for files that it needs to translate into a format that is suitable for the WD Photos mobile app.  If you disable remote access - I believe this will disable that background task as well.

The fact that you have a blinking green LED on the front - indicates that the drive is in fact actively processing something.