3TB My Book Essentials will not install on USB 3, works fine on USB 2

Recently purchased a new PC…


ASUS Z87-K motherboard


2GB GeForce GTX 760

Clean install of win 7 Pro 64bit (service pack one and all other updates are installed)… when I plugged my 3TB My Book Essentials external drive into the USB 3 port, it popped for installing new hardware, then I get an error message saying that the device failed to install.  Error message is that the device is unplugged (obviously it is not, Win popped that it found new hardware)

Device Manager displays this as a USB Mass Storage device under USB Controllers.  I have uninstalled the device and it will automatically pop that it has found new hardware and will try the install once again.  Result is failure…

What other steps have I tried?

  • Verified that USB 3 is enabled in the BIOS

  • Downloaded and installed the lastest USB controller drivers from ASUS

  • Downloaded and installed latest WD SES driver

  • Tried a second USB 3.0 drive (1TB USB WD Passport) works perfectly in the USB 3 port

  • Tried swapping USB cables from both drives

  • Disabled my antivirus, unplugged the drive… plugged in… same issue

  • Computer Management will not list the drive, even though it appears as USB mass storage in Device Manager

  • Plugged the drive into my USB 2.0 ports - works fine… but I get prompted to plug into USB 3 port for faster speeds

  • Tried this 3TB drive in my old system… again that was using 2.0… worked of course

I’m running out of ideas… could use some help.


Again, please note that I have tried a 1TB WD Passport drive in the USB 3 ports and it worked fine, so I know my ports are working.

Try connecting the My Book to another PC to see if the problem continues, also try running a DLG test. 

How to test a drive for problems using Data Lifeguard Diagnostics for Windows

The drive installs perfectly on my ASUS laptop via USB 3.0

Other drives work fine on my i7 PC via usb 3.0, only 3 TB drive is causing me issues

Any other suggestions?