3tb hdd wd30ezrx

I just got this nice player and tried running with a 160 GB usb drive, no issues.

Now i have a WD 3TB - wd30ezrx installed on a Rocketfish casing which works fine on my PC. But i am unable to see the drive on the Media Player.

Any suggestions guys?

You probably need to update the firmware. 

http://wdc.custhelp.com/app/answers/detail/a_id/5749/session/L3RpbWUvMTM0MDU3NDc1NC9zaWQvby1COWR2X2s%3D

Forgot to mention its already on Firmware Ver. 1.09.10

Any help guys ? I am totally lost here

Have you tried the front and rear usb ports?  My 3tb drive (USB3) only works when plugged into the front USB port.

yep I tried both ports

just spoke to wd cust care, they told me ext powered 3tb drive will not work, In fact 3TB drives will NOT work on this media player .

Is that true ?

not true. I’m currently using a WD 3TB Elements drive its USB & requires it’s own power.

if I recall correctly the SMP did not support anything over 2TB but a early FW update added support for 3TB drives.

I tried explaining it to the customer care. They refuse to accept the fact that this player does support 3TB drives.

It’s not the drive that’s at issue, it’s the case.   Some USB cases do different things with their USB/SATA bridge hardware.

The drive will most likely work if it’s in a dock or external case that works with the WD.

Well I have tried 2 different casings.

  1. Rocketfish - http://www.rocketfishproducts.com/products/computer-accessories/RF-AHD35.html

  2. Nextar CX  - http://www.vantecusa.com/gl/product/view_detail/374