3D mkv Playback

HI Friends

I played one 3d movie in smp. it is playing the file but image appears everything is double and the tv also looks like it is in too far and smaller, also  2 lines appearing in each boader on my lg 3d tv. when i played directly on my tv  it looks fine . So nothing wrong with the file. Why is that?  Does anybody have same issue?

Sorry for my bad English

Please post the full TEXT output of MEDIAINFO for such a file.


Unique ID : 
Complete name : Transformers Dark Of The Moon 2011 ((3D))\Transformers Dark Of The Moon 2011 ((3D)).mkv
Format : Matroska
Format version : Version 2
File size : 13.4 GiB
Duration : 2h 33mn
Overall bit rate : 12.5 Mbps
Movie name : Transformer.3.3D.2011.1080p.Half-SBS.Bluray3DRip
Encoded date : UTC 2012-01-22 22:25:19
Writing application : DVDFab
Writing library : libebml v0.7.8 + libmatroska v0.8.1

ID : 8
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.1
Format settings, CABAC : Yes
Format settings, ReFrames : 2 frames
Duration : 2h 33mn
Bit rate : 11.8 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.237
Stream size : 12.7 GiB (94%)
Writing library : x264 core
Default : No
Forced : No
Color primaries : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
Transfer characteristics : BT.709-5, BT.1361
Matrix coefficients : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

ID : 9
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Codec ID : A_AC3
Duration : 2h 33mn
Bit rate mode : Constant
Bit rate : 448 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 493 MiB (4%)
Language : English
Default : No
Forced : No

Sounds like your TV is not Auto Detecting the 3D via the HDMI

Try another HDMI preferably a 1.4 version  or  does your LG have a “Manual” 3D button ?

Select  “Side by Side 3D” 

Connecting a USB directly to your TV and playback is fine… proves the file is OK.  

(Direct connection via your TV’s USB,  the 3D Auto Detection is Instant) 

Well, the WD isn’t going to change the TV mode to 3D automatically anyway.  You’ll need to do it manually.

Another possible issue is that the profile is High@L5.1.

The WDTV doesn’t support that profile, so it may not play well, if it all.

Well, the WD isn’t going to change the TV mode to 3D automatically anyway.


I Didnt say or imply that…

Sounds like your TV is not Auto Detecting the 3D via the HDMI


My Panasonic 3D TV automatically switches to 3D viewing mode when it detects 3D Content.


Works for Side by Side & Over and Under 3D content.   (Picture below is not my model, but mine has similar settings)

I was assuming LG uses similar 3D detection techology.

Interesting.  No, LG (at least my model ) doesn’t auto detect 3D unless its coming from an HDMI source with the 3D flag set…

For example, Vudu on the WD uses 3D SBS, and my TV switches with that because Vudu tells the WD that it’s 3D, and the WD tells the TV using 3D signal notification flag.

Oh, and the other thing to think about here is that there is no longer any such thing as HDMI 1.4 (or any other version, for that matter) cables.  

The HDMI licensing corp did away with all that…  Consumer products can also no longer refer to any specific version number compatibility without explicitly stating which portions of the standard they support.

For instance, WD violates that rule by saying the Hub has HDMI 1.4 and the SMP has HDMI 1.3…  They don’t state which parts of that standard they support.  Example, 1.4 includes specification for Ethernet and Audio Return Channel, which WD obviously does NOT support.  :)

All that is needed for full 3D support is HDMI High-Speed spec cable.

Hi Friends

       thankyou for your reply. My LG tv did not detect 3D video via smp but when i plug tha harddrive directly to tv it detect the 3d and automatically switchefd to 3D mode. So what i did when playing in my smp i manually press 3D button and Select  “Side by Side 3D” .