30500 when trying to enable Twonky after factory reset

I’ve been trying to get to Twonky to work again so that it will stream media properly to my Xbox One. I logged in to the dashboard, gone to Media > Twonky and when I do I get the following error:
30500 - Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance.

I also tried to switch to WD’s Media Server via the firmware update posted here: http://support.wdc.com/KnowledgeBase/answer.aspx?ID=5735 but I got an error saying
31101 - Invalid firmware package.

Any ideas? I have a feeling that my only option will be to do a full factory set and wipe the whole box but I’ve quite a lot of stuff on there so I’m hoping to avoid that if possible.

Are you using a MyCloud? Because the MyCloud Dashboard media server control is at Settings/Media/DLNA Media Server. It doesn’t mention Twonky.

And no, you won’t be able to load a MyBook app onto the MyCloud.

This might help:

Have you tried adding this, :9000, onto the end of your WD My Cloud address.
Example: (