30401 - You are not authorized to perform this task

When I try to secure the device, this message comes through:

  • 30401 - You are not authorized to perform this task.

Additionally whenever I try to add or delete users in the drive sharing, also the same error message comes in - Not Authorize to perform this task. Changing the share also the same error

Can anyone please help?

Exactly the same for me - reported to WD who told me to log a RMA request, but when I try this it tells me my drive (bought in January 2011) is out of warranty.  I’ve also tried doing a full factory reset but nothing changes - the drive still doesn’t work.

contacted Western Digital they asked for a full factory restore… Well still need to do backup first…

in the meantime, i will try a firmware upgrade first…

Well I tried a full factory restore, a quick factory restore, a reset (button on the back with a pin) and reinstalling the firmware via the web interface and also via the command line through Putty but the same error returns - nothing fixes it.

Well, if it is any info for you, I upgrade the firmware with Putty then after I am unable to connect to the MBL anymore. It is either giving me solid yellow light or a solid green light but I am unable to discover and see the IP address of the MBL anymore. Prior to the upgrade, I make a report of the log of the MBL, I found the log memory was already full. May be the problem is just the log was full --> dev/md0 (see below)

Filesystem            Size  Used Avail Use% Mounted on
/dev/md0              1.9G  1.9G     0 100% /
tmpfs                  50M     0   50M   0% /lib/init/rw
udev                   10M  6.5M  3.6M  65% /dev
tmpfs                  50M     0   50M   0% /dev/shm
tmpfs                  50M  3.2M   47M   7% /tmp
ramlog-tmpfs          1.9G  1.9G     0 100% /var/log
/dev/sda4             1.9T   49G  1.8T   3% /DataVolume

do u know how to delete the log?