30 second wait for each keypress after Firmware upgrade

I just did the online firmware update to 1.06.16 B and it did bad things.  After it finished, the first problem I noticed was no video.   I resolved this by unplugging and re-plugging the hdmi cable.  I have to do this each time I reboot it now or I get no video signal. 

The next problem is that it will not take the next key press from the remote for 30 seconds after each key press.  It’s exactly 30 seconds.  It doesn’t buffer the key presses.  It just won’t take them.  So it is *** extremely *** painful to navigate the menus.

The next problem is that the reset button is ignored.  I was going to follow others advice to reset to factory defaults, but I can’t.  I tried holding it in for a long time and no luck.  I know that I am pressing it as I can feel it click down when I put the paper clip in.

What now…

Reset it from the menu.

Can anyone tell me exactly where the reset is in the menu and how to get there with the fewest key presses?.  I gave up looking for it.  As I said it is incredibly frustrating to wait 30 seconds just to enter one more key press.   Thanks

Ok forget the menu. Press the side paperclip button for a few seconds and then release with the unit fully booted up. It should reboot. The reset button is on the side next to the usb port and access is via a small hole, that’s why you need something like a paperclip or cocktail stick.

… and if it still doesn’t reset, then your box is dead.

As I said in my first post, the reset button is unresponsive.  Some devices have a hard reset mode that is activated by holding in the paper clip while powering on the unit (plugging it in in this case).  Does anyone know if there is such a feature?   Or does everyone agree that the box is dead if the reset doesn’t respond?  If so then I guess it’s worth a try.


Does WD support these?  I shouldn’t have to lose my box because of their bad firmware.

OK here are the key presses.

From ‘Video’ go up 2 presses to ‘Settings’ (enter), up 1 press from ‘Audio/Video’ to ‘System settings’ (enter), up 6 presses from ‘Set Time Zone’ to ‘Reset to factory defaults’ (enter),. Press OK on message ‘Are you sure you want to restore this device to factory settings?’. The unit should then reboot.

Good luck.

By the way the reset button is a push and release type. If you hold it in for 10 seconds or more it will change the standard from PAL to NTSC or vice versa. The reset button only works when the device is fully booted up so no the press and hold while powering up does not work - I believe that this approach only applied to certain modem/routers.

richUK, thanks so much for the help.  It took about 10 minutes but I was able to get to the reset option with your great instructions.

Unfortunately for me, factory defaults didn’t save the unit.  It seemed to go through the process just fine and then rebooted.  But the 30 second pause after each key press is still there (actually now it’s around 45 secs).  My only other option is to try to downgrade/upgrade the firmware from a usb stick.  Where is this option in the menus or is it something that happens during boot if the correct files on the usb stick are in place?

Thanks again!

Get the rollback firmware from the link below. Make sure you get the correct firmware for your player. Put all the unzipped files on a clean flash drive and plug into the USB port. After a while a firmware update screen should appear in the menu. You then take it from there with a few key presses. Good luck