3 WD network devices, unable to Map 1 of them

Hi all,

I currently have one My Book Live, and 2 My Clouds. They are all attached to my virgin superhub 3 router (via a switch). I am able to access all three devices via their ip address through a web browser. I am also able to access all 3 devices’ files using windows explorer. All three devices show up as Network Locations in windows explorer, and as storage devices in windows explorer. All three devices show as connected devices in my router settings.

I am able to map the two My Cloud devices, however the My Book Live device will not map.

The error code is “0x80070035 The network path is not found”
Windows Network Diagnostic says “The Device or resource (192.168.*.**) is not set up to accept connections on port ‘The file and printer sharing (SMB)’”

The My Book Live device UI page is showing everything as working fine.

I was able to map to the My Book Live (and the other two WD drives) without any issue up until a couple of days ago, although I would have to re-map the network drives everytime I powered down, and then restarted, my laptop.

Any ideas would be very much appreciated!



I am using Windows 10, and have attempted to map the network drive using the ip address in the windows search bar, in the ‘address bar’ in windows explorer, right clicking the device icon in Windows Explorer Storage and ‘choosing mount public share’, and using ‘Map Network Drive’ and entering the ip address (\192.168.*.**\public).

Hi, have you tried pressing the reset button in the back of the drive? Have you tried mapping it with the drive name?

Reset worked!

Such a simple solution, I have no idea why I didn’t try that first. A lesson learned, thank you very much.