3 TB Red...dead? :(

Had a 3 TB RED drive I was using in a Windows 7 machine for backups, wanted to use it as a multi system backup repository. Formatted in in FAT32 to see in both Windows and my wife’s Mac… and now its just dead? I’ve got it in a Inateck enclosure that works with other HD’s, but I can’t get the disk to mount to either computer in the enclosure, or plugging it back in to the original PC.

Drive won’t even show in Windows, I can see it in CMD/DISK PART, but attempts to format or partition there get a CRC error.

The Mac recognizes it as a HD, boots Disk Recovery, I try to erase and reformat (have tried all possible formats) and keep getting an error about “Unable to write to the last block of the device”. I’ve tried all the tricks in Terminal to no avail.

WD utilities have proved fruitless on both platforms. Time for the trash and grab another brand next time? Pretty disappointed in this product…

Hello,

Based on the information you have provided, recommend you get this drive replaced.

Click on the link below to verify if your drive is still under warranty.