3 TB My Book not being seen as a bootable drive for OS install

I purchased this 3 TB 3.0 USB My Book

( WD My Book 3TB USB 3.0 Hard Drive with Security, Local and Cloud Backup (WDBFJK0030HBK-NESN) http://www.amazon.com/gp/product/B00E3RH63A/ref=oh_details_o00_s00_i00?ie=UTF8&psc=1))

It works fine as passive storage device but I want to use it also for installing one or more Linux operating systems and running them (one at a time via dual boot) on separate partitions made for each OS. The rest of the free space I’ll use for backup storage - at least thats the plan, if i can make this drive seen as a bootable device.

My system specs are:

System Manufacturer/Model Number - HP Pavillion G7-2251dx
OS Windows 8 64 bit
CPU AMD A-8 4500M
Memory 8 Gigabytes DDR3 sdram
Internal Hard Drive 500 gig

Spec info from HP on my laptop - http://h10025.www1.hp.com/ewfrf/wc/document?cc=us&lc=en&docname=c03561498

I have tried to install Zorin 7.1 (Linux) to the drive from a live ISO. It installs well enough untill it tried to install grub at the end of the instalation - it cannot ever install Grub as if it’s not finding the MBR area on the drive. I had set up a 100 gigabyte partition formatted to EXT 4 for this purpose.

I also tried to install a live version of the distro via Unetbootin and Unetbootin cannot see the drive at all - even after re-formatting Fat 32.

Now, to me, this is silly becuse it’s just a normal mechanical hard drive like all other mechanical hard drives - only being fed through a USB 3.0 interface. My PC is USB bootable - in other words, i can install that Zorin OS to my 30 gig USB Flash stick and the PC will boot into the OS from start up normally. It just don’t seem to want to do it with the USB mechanical drive.

Why is this?

Is it a setting I am missing (doubtful)  - Is it a limitation of the USB interface WD is using? - Is it because of a Jumper Setting on the mechanical drive that needs to be moved to another position?

Of all i can think of… option 3 a jumper setting seems most likely, but i want input from those who has had this problem. 

Can you help? Thanks.

Your main problem here is MBR since WD drives above 2TB need, use, and come with GPT and not MBR. Formatting the drive and the file system won’t change that.

You need to zero out the unit to destroy the core partition table, and initialize the drive as MBR instead of GPT but if you do that the drive will either show 2TB or 700GB with no way around it since the sectors and discs were made expecting GPT.

Also, if you take the drive off the case it’ll stop working forever because of the encryptio, which is always active.

I was wondering what that GPT garbage was… LOL… I just tried to install Zorin again without my internal drive being installed… this time it did install grub and it seemed that the install finished properly asking me to reboot to use it -but my system still would not read the drive of course… now i know… cus of this GPT garbage. ( i saw the OS was installed under GPT in Mini Tools Partition wizard from win 8 and wondered about it)

You say WD drives above 2 TB’s need this GPT stuff… what about other brands? There has to be some that do not, there are tutorials all over the net where people install Linux on the 3 or even 4 TB external USB drives…

er… So… your telling me i need to get my money back for this drive and buy another thats not WD - which one do you suggest ?

Edit, Scratch that last statement… I just found out it’s a limitation of the Legacy Bios MBR itself. Thats why WD is using GPT.

[quote]Most legacy systems built before 2011 have a traditional PC BIOS. This type of BIOS uses a Master Boot Record (MBR). The MBR Partitions can define a disk drive capacity up to 2.2TB. Windows operating systems that boot from an MBR are therefore limited to 2.2TB per MBR.[/quote] http://knowledge.seagate.com/articles/en_US/FAQ/218619en

So the trick is not another brand of 3 TB external drive of another brand, I’d have to get at most a 2 TB drive. It won’t need to use GPT.

So remember folks… No 3 TB externals will Ever work to install Linux onto

(except perhaps unless your using UEFI instead of legacy Bios - which I haven’t tried cus UEFI doesn’t play well with most Linux distros - my goal was to have 3 100 gig partitions each for a different linux distro and I won’t be able to do that with GPT even under UEFI because i’d be limited to a few select Linix distros.)


Thats ashame and **bleep** bad cus i got this 3 TB’s worth of space for only 109 including shipping.  I’d have to find either a 2 TB and a 1 TB for the same price total to do what i need to do.



JohnPhoenix wrote:

You say WD drives above 2 TB’s need this GPT stuff… what about other brands? There has to be some that do not, there are tutorials all over the net where people install Linux on the 3 or even 4 TB external USB drives…


er… So… your telling me i need to get my money back for this drive and buy another thats not WD - which one do you suggest ?

That’s drive-specific instead of vendor-specific.


Mostly, drives with actual platters over 2.1TB+ instead of several smaller platters adding-up to 2.1TB+ need GPT. You can “force” MBR on a 2.1TB+ drive with formatting tools but it will eventually degrade performance because partition table, sector count and FS behavior won’t be set in proper alignment to bypass limits of MBR.

And also, evne with proper MBR partitioning there’s no way to garantee it will still work because of the encryption. Take it back, and if you’re still going for WD then the only one I recommend is the Elements WDBAAU because it’s the most plain drive ever made, which works best IMHO.

Just make sure it’s under 2TB as well. From other brands I can’t tell since my only drives over 2.1TB are all WD. My Seagate is 2TB and my iOmega is 500GB. 

LOL… i just editd my post above… you may want to consider it… i’ll go read your post now.


 I read it… yeah… pretty much the same as what i found out… I wish this info were more commonly known and reported… i didnt find anything like that when researching what drive I wanted to buy. Now i need to still get my money back for this drive and consider my drive options again. Bummer.


I don’t believe these external drives are bootable regardless of size also Linux is not one of the listed OSs.


Well Joe thats an opinion going in the oppisite direction of a favorable outcome.

I suspect because the drive is set up for GPT WD also suggests it work with UEFI and therefore not suggesting Linux makes sense… ( Only because there are only a few linux distros out of thousands that have UEFI support) but it cannot be a drive limitation. It’s just a hard drive - it doen’t care what data is on it or what it’s doing and nor should WD care what you do with the drive…

It makes sense to me that  drives with 2 TB’s would work as well as any other drive for booting Linux becuase they still use legacy bios and an MBR.  WD in this case would not deem itself so proprietery as to deny support for Linux - that would be unheard of and absurd IMO.

If you have information to the contrary plese post it. I have to make a decision soon and I cant buy another drive thats not going to work.

  My system now is set up to use Legacy Bios Mode. I plan to finish backing up my current system and re-enabling UEFI and secure boot for my next install. I’ll then try installing Zorin 7 to the 3 TB external as Zorin 7 does support UEFI. This should work fine though I’d still have to get another drive for any Linux distros that do not support UEFI.

I’ll report back on how well this works when i’m ready to try it.

1 Like