3 Tb My Book Essential

My 3 Tb My Book Essential ext drive works OK here on several Lenovo PCs running either XP or Win7-64.  Then when I try it with my new Lenovo T530i on either USB 2.0 or USB 3.0 ports, the access to my files on the drive seems fine, but surprisingly I get a Lenovo diagnostics Random Seek Fail test result.  Also, with the 3 Tb ext drive connected, the Boot process always “freezes”, regardless of re-start or cold start.  I tried re-setting the Boot priority in the BIOS, but that didn’t help.  I ran WD Data Lifeguard Diagnostic for Windows on the “problem” PC for the 3 Tb ext drive, and the test result was OK.  Lenovo Support had no new ideas about this issue.  Any suggestions?

The boot issue is normal in certain computers

the bios is trying to boot from the external drive

disable boot from USB and Legacy USB support ( the latter only if not using an usb mouse or keyboard )

not sure why reporting random seek fail but you can disregard if the test shows the drive is fine