3.03.16 Have to unplug from power to make it play a file

Hi !!

3.03.16 has to be unplugged from electrical power to make it play a file (video, photo, MP3).

After turning on the unit and navigating through “Files” and selected any kind of file and pressing “OK” on the remote all I get is the orange arrow turning clock wise eternally.

To recover the unit I have to unplug it from electrical power to make it work again.

Anyone having the same problem?



A lot of people. Its known as the Spinning Arrow of Death (SAOD). Search the forums here for those terms you’ll get the low down on it.

 I had to roll my firmware back to version 2.07.17 to get rid of it. You might try reinstalling the firmware you are currently using to fix it. You symptoms are somewhat different so it might work.

I havent installd this firmware after problems with older ones.best thing you can do is google(how to roll back wd firmware for wd live hub).thats where i went to,to roll it back to one i used&worked before.seems that wd want people to call them&get charged for there help when you can sort it your self.you will need a mem stick or external hard drive.turn off your auto detect new firmware on hub&leave it off.allways check as i do now bout new firmware.hope this helps.


I din’t expect this response, but let me tell you my friend LOL !!!  :smiley:

Ok, last firmware version that I remember worked well and stable was 2.07.17 and I tried to roll back but didn’t work. I must have done something wrong.

Can you point me to the correct roll back procedure?

Thanks, e1375

Here is a link to the instructions…really not much different than doing an update from a USB device. Make sure the USB memory stick is formatted properly (FAT32).

Say goodbye to the SAOD! :slight_smile:


I have no problem if  my WD TV SMP does not want to play a particular file, but why do I have to uplug it and plug it in again  to be able to play another file (that I know plays perfectly) ??? If I don´t it just starts the Spinning Arrow of Death if I try to play anthing else. I gave this 5 stars on Amazon but this problem is a real turnoff. I suppose I will have to get a remote for my electrical outlet.