2TB WD MyBook (second time my disk is unreadable!)


#1

Sorry to start like this but WD External HD products seem to be the biggest pieces of ■■■■ I’ve EVER come across!

What’s worse is WD software and support seemingly **bleep** AND are non-existent!!

Why do people buy external HD’s? To keep data SAFE… stuff you DON’T WANT TO LOSE!

What CONSTANTLY happens with WD External Drives? Systems no longer recognize them and simply ask you to reformat the disk!!! Therefore your “safe data” is GONE!

This has happened twice to me with the same disk.

I have colleagues that have the EXACT SAME ISSUE with WD Mybook drives. Seriously WTF is the problem? I have other external Drives made by Lacie and other brands… NO ISSUES… EVER!!

I have about 300GB of vital data on my 2TB MyBook (mirror edition). The most important data is a 240GB IMAGE I created of my PC that has completely crashed!  Installing the WD drive manager it reports that the “RAID has FAILED” and wants me to reformat (as usual). It shows up in disk manager but cannot be found nor accessed under My Computer. I currently am using it in 2TB mode not in 1TB mirrored mode (well I was using it in that mode until it decided not to be recognized AGAIN).

I tried updating the firmware. It finds it, starts trying to update and just exits with “FAILED”.

I hope someone here can help, however I doubt it… seeing that pretty much 100% of the posts on here have gone un-answered or NOT successful…


#2

I finally after desperation took out each disk out of the WD MyBook enclosure and hooked them up to an external cradle I have. one of them comes up as a 931.GB drive (in Disk Manager) but not in my computer. The other one comes out as a 1871GB drive (it’s set to be a 2TB disk, two 1TB disks).

Does that sound normal? O.o

I’ve tried swapping USB cables to 5 different one’s I have running other things. I’ve tried several PC’s and Windows XP and Windows 7. I still cannot see my data on my MyBook Mirror Edition. I desperately need my data. What can I try? Is there anyway to take the disks out and get them to work some other way?


#3

Have you tried contacting WD customer support to have your drive replaced?  Keep in mind that the drives are designed to be used with their specific bridge boards and may not mount when used on a 3rd party bridge unless formatted and partitioned.


#4

Western Digital what can I say,

 hi people I am joining the ranks of those who are in some kind of trouble because they put faith in a Western Digital product. I think their would not be as many people here if we had more information about this hard drive before we purchased it.

I am an announcer and like so many others I too have (or had) information that I need to save because it needs to be used often. Now to be fair I have a 500Gb drive that’s been on for about a year 24/7 with no problem and that’s why I think I bought this one. This is a My Book Essential external hard drive. With WD quality and USB 3.0 and USB 2.0 connectivity. It’s partitioned and I have a drive called Information (I) and another called Music (M). Now people let me set this up for ya. The 2 TB is plugged into the rear of the tower with plenty of ventilation. At the time I was working on a jump drive cut and paste off the net, not doing anything with the My Book when I see in the corner of the task bar a message saying not writing to m drive, then it fades away. A few moments go by and I see not writing to I drive and it fades away. I think to myself (That can’t be right). So I click on the my computer icon on the desk top and at the same time I see that some of the icons are gone, but when My Computer opens I see Information (I) and Music (M). People the smile went away when I right clicked on music and the word disappeared and the word local appeared with no drive letter and the same for information. At that point I went to system restore thinking it might be able to help but the words came up saying that system can not restore I or m drive because it is removed from the system do you want to continue. I at that point clicked out of the program and shut down the PC. I took the 2 TB up to the kitchen and plugged it into my laptop. At first a ray of hope when the system said that a drive needs to be checked and do you want the system to fix any problems you know I clicked yes. At that moment the system locks up. When I unplug the 2 TB drive things go back to normal on the laptop and P.C. Is this in fact a problem a lot of people are having or just me. Anyone have any ideas how to fix this. By the way the drive is registered on the site and it’s only 34 days old.