2TB WD MyBook HDD overwritten, now showing only 32GB

I made a classic mistake when creating a Recovery USB, overwriting my 2013 2TB WD MyBook HDD instead of the USB Flash Drive. Am using Windows 10. I have removed the Recovery files leaving none showing. When I try to restore any of several previous versions of the 2TB drive I get an internal error. Using File explorer I see that it reports that the 2TB drive is only 32GB. I am guessing that as my previous versions will be more than 32GB, that may be why I get the error message.
Advice welcome, at ■■■■■ level, how I might get my 2TB back and if poss restore previous contents.
Tried to find the Windows error code by attempring repeat reinstall previous version, now getting no response.

Hi, When you go into disk management, do you see the full size of the drive? Have you attempted to use a data recovery software?

Hi. Using Windows Disk Management I get conflicting results.The top panel shows the drive as having 32GB, the lower, where more detail is shown for each drive, shows 32.00GB FAT32 Healthy (Active, Primary Partition) and then 1830.98 Unallocated.
Using WD Drive Utilities shows 1.82TB.
I have not used any data recovery software other than trying the Windows/Properties/Previous Versions/Restore.

Hi, can you please post a screenshot of disk management?

Hope that is visible. Disk 4 F is the HDD concerned.

Hello, I was able to see the image and realized that you formatted the drive in FAT32, normally FAT32 only support up to 32 GB that’s the reason why you only see this, I have seen users using some other software to format larger drives in FAT32.

Note: following any of the links below will delete the information on the drive.

Check this link if you still want to use the drive in FAT 32.

If you want to have the full 2 TB of storage and don’t mind not having it in FAT 32, then take a look at this link.

Thank you so much for the suggested course of action.This seems to have worked to recover all the disk space AND I have found a back up of the drive that is less than a month old so it looks as though I may be able to recover the bulk of the data that was on the drive. It is just as well I have a back up as the restore option still will not work (error message code 0x81000036). I think the process of trying to create a recovery USB stick was the point when the FAT32 format was invoked. Thank you for your assistance.

Anytime, remember to mark the post that assisted you as a solution, that way any user that might be experiencing the same issue will be able to know which post helped.