2TB WD My Passport will not work through USB 3.0 Hubs

The WD My Passport 2TB will not work with a USB 3.0 Hub. It must be connected directly to the USB 3.0 port to work.

I have 32 External Hard Drives, 16 of them are USB 3.0 drives of 2TB & 3TB capacity made by either Western Digital or Seagate. All of them work through my two different kinds of USB 3.0 hubs without any problems. The only exception to this is my latest acquisition, the Western Digital 2TB My Passport 2 1/2" external hard drive. It seems to only want to work if connected directly to the USB 3.0 ports on my PC using the ridiculously short 12" ish cable.  I’ve tried different cables to no avail. I tried powered hub, non-powered hub, still no go.  To make matters worse, when I attach this drive to the same hub as my 1TB My Passbook purchased a year ago it drops the 1TB off the hub. Now these are the only things attached to the hub and it has a 2.5 amp switching PSU, which should be plenty of juice to drive two little hard drives.

To me, this drive is a FAIL and it is going back to Costco for an exchange to see if it is a lemon or of this is par for this drive. (Ooooh, bad pun).

USB hubs are not recommended because they usually don’t provide enough energy, you can try using a powered USB hub. The cable is short because the longer the cable the less energy the passport will get.

NOTE: I posted this same response 4 days ago and it has been deleted. Very strange. I will post again.

Update: Monday January 7, 2013
Thanks for your reply. I am a computer engineer with an electronics engineer education with 32 years in the computer profession doing everything from PC hardware, systems administration, networking, and business integration. I understand how these products work at every level from the electrons, through the circuits, the protocols, the integration and the applications. It’s easy for WD to say  a hub is not recommended, but that is not a fair response. The package makes the claim it is USB 3.0.  It does not say “except for USB 3.0 hubs”.  All their other USB 3.0 drives work fine in the same configuration.  This includes UBS powered models like my 1TB My Passport Essential.
I exchanged the drive for another at Costco. It has the same problem. The 1TB model of this drive works fine, but this one can only work directly attached to a USB 3.0 port, no hubs or cable extenders allowed. I am not giving up one of my USB 3.0 ports just to have one drive attached. This is a total FAIL from WD.

BTW, while I do not use the power supplies for any of my USB 3.0 hubs because they work fine with all the self-powered drives attached and even one USB powered one from WD.  I did go ahead and try a few of my hubs with the power supply, one with a powerful 2.5Amp power supply and then I tried it on a hub with a 4.0amp power supply, still no go.  I have multiple other WD My Passport drives, including a recently purchased 1TB My Passport Essential model as well as 32 other Western Digital, Seagate, & a couple Lacie external drives, most of them USB 3.0… All of them work through the hubs except for this one. I get that the Passport drives are USB powered and need juice. I am absolutely convinced it is getting plenty of power. I have tried every combination trying to get it to work. It is not meeting the USB 3.0 specification if it cannot work through a total of 4 feet of cable and a powered hub.

It’s to bad, I will just return this one too. Maybe they will get it right again with the 3TB model.