2TB, USB 3.0 - Device not recognized

I have just pulled my WD My Book 2TB USB 3.0 out of the box and when plugged into the computer it does not recognize the device and states that the USB attached to this computer has malfunctioned.

I have tried connecting through my USB 2.0 and 3.0 ports, yet the message is still the same (device not recognized).

I have successfully tried connecting it to my laptop running windows vista so I know the hard drive isn’t faulty.

I have also tried to use the windows update to try to locate the correct driver.

My OS is windows 7 Ultimate 64bit and my motherboard is a Gigabyte X58A-UD7, if that makes any difference. 

My understanding is that the OS should just have the drivers all ready for this hard drive to start working straight away.

This is pretty frustrating so if there is anyone out there who may be able to throw some light on this I would be very grateful!


Any drives that come with SmartWare have the SES driver on the Virtual CD in a folder labeled Extras or in the Extras folder on the drive itself.  If you go to Microsoft’s web site, get the latest service pack and the USB drivers updates for your version of Windows.