2TB Passport Locks Up

I have a 2TB passport drive, never abused or dropped (about 2 years old). It is detected when plugged in, LED is blinking rapidly. I can navigate through folders on the drive but after about a minute it makes a single click and locks up. LED keeps blinking and drive still spinning. Drive still shows as connected but I can not access anything. Every few minutes it will make another single click. If I unplug the drive and then reconnect, I can access again until the click. If I run WD Utilities Status Check before the click occurs, the drive passes. If I run it after the click it fails. I have tried swapping the cable with another drive without success. Is this drive dead?

Hello,

Try running a diagnostic using WD DLG.

Data Lifeguard Diagnostic for Windows

The drive does not stay connected long enough for me to run a diagnostic. Since my original post it now only stays connected for a few seconds. If I plug in USB with DLG already running the drive shows up with Smart Status PASS but then disconnects. Really, I am not sure if it is disconnecting or getting stuck mounting the disk. If I connect a second passport drive with the bad drive still connect, the new drive does not show up until I disconnect the first one. I have 3 of these drives. I have swapped cables between them so I know it is not the cable.

When I plug in the bad drive the drive letters show up (it has 2 partitions) but I can not access them. Also tried on Mac and Ubuntu but still can not access. I read a few posts of others having similar issue using HDDSuperTool (http://www.sdcomputingservice.com/hddsupertool) successfully. However, the drive disconnects (or gets stuck) before I can do anything.