2TB MyBook Live not seen on network


My 2TB MyBook Live was working fine until last week. I see steady blue color and intermittent orange/red color. I can’t see it under “Shared” in my MacBook Pro (where I used to see until last week). 

I’m not sure what went wrong. I can’t access it via browser or WD Quick View. Any help would be much appreciated. Please guide me if more information is required. I shall extract and provide.

I can’t see any IP address assigned for this in my router which is on DHCP. I’ve no clue on what is wrong?

Is there any way to access my MBL like directly connecting via ethernet to my MacBook Pro or by other means?

Thanks in advance.



Hi nikonian, have you tried doing a power cycle? You can also try pressing the reset button on the back for the My Book for 4 seconds (this won’t delete your files).

Thanks for your reply. Do you mean switch off and switch on as power recycle? If yes, I’ve tried that few times and still it didn’t help. I’ve tried reset too and it didn’t help too. I’ve tried connected directly to my macbook pro using ethernet cable and still didnt help.

Are there any otherways left? Appreciate your help. Thanks.

If under warranty, I would open a case with WD first.

If not under warranty, there are some guides to debrick it. In this link, both guides, one to recover data and one to just debrick are mentioned. All this assuming there are ONLY software issues.


Try using another Ethernet cable, if the problem continues you can follow the link below for the steps to replace it.

How to get an  RMA, (Return Merchandise Authorization) or replace a defective product under warranty