2TB my passport for MAC

Hi all

My son has a 2TB my passport for MAC external HDD that a while ago was not recognized anymore by his MAC Pro. I scanned the drive with a third party software, which still recognizes the partition in HFS+, to retrieve the files from the drive .I am able to retrieve a lot of data from the drive but all the content of the files are 0. The files are shown to be part of a folder structure that has actual folder names and the images, for example, have real names but can’t view any files. As I said, all the files show real file size but when I tried to look at the file, none of them can be viewed. I am wondering if the drive is completely garbage now even if I am able to see all the files. Any possible solution to this issue.

Thank you in advance for any help or suggestions

Hi mrtek,

Test the drive with WD drive utilities using the links:

If the test is unfortunately inconclusive and you just purchased the drive then you should be able to return it to the place of purchase or else you can contact to WD Customer Support.

Hi Clara

Thank you for your reply. I tried both utilities and did not fix the issue.

…and the drive I believe is not in warranty anymore.

Thank you

Hi all

The drive that I have is a 2TB my Passport for MAC. This drive has a 200MB EFI partition and one 1.8TB HFS+ partition. My understanding is that the EFI partition controls the boot process. Can somebody tell me what format this partition should be? Is a an ExFat, Fat32, etc…

Thank you in advance for your help.