2tb My Book Files- Unallocated Space, need to recover


thats the image when I go to manage, I dont know what happen but I seriously need the files from my 2tb.

Any software or stuff pls tell i need it badly


On my 2TB Book Essential it does the EXACT same thing, right down to the sector number,.  I have a 1TB model foing something only slighlty different. All I know to do is to keep looking for a good external partitioning and formating program because I do not believe I puchased TWO models in a row from the same reputual store with these problems, I assume its a problem that can be fixed on this end. If you solve your problem PLEASE post it here so I can stay in the loop. eh?

Thanks! :slight_smile:

Dude you also Please I really need a solution badly and it hurts enough to know that there is only a slight chance that it might break, Please tell if you found any useful things

Sure thing bro, this is VERY important to me because I had used the money I made repairing another computer to buy a 1 TB and a 2 TB drives to help backing up data. Long story short, we seem to share much the same problem. I checked and my exact sector count was off by about 15 points, otherwise it is the wame with the black line and the word unalocated. I assume that means it needs to be partition but my Windows 7 Ultima will not do it without bugging out in quick format mode, and locking up in slow format mode… I really want to find a new partitioning and formatting program for usb external drives.

I will check here everyday untill a solution is found, I have plenty of time and I do not give up easily on troubleshooting matters because it is how I make my living, even if I do appear poorly at troubleshooting right now. Nobody is perfect, we all need to ask for help sometimes.

I think the problem is the external itself for i tried in 4-10 pc since yesterday

Dont worry I will try to find the best solution, I using test disk now a free software but it will take hours to be finish I will tell you the results after that

Any word on this? I have a Western Digital My Book Essential with a 2Tb drive that’s flaked out. I slaved it to my Win 7 (64 bit) machine and am seeing the EXACT same error.

Thanks in advance…