2TB Internal HDD, finally formatted--now Drive Letter won't stay past Restart


#1

Abstract

My Carver 2tb internal HDD is finally formatted. But, now the drive letter(s) won’t stick. I’ve tried several programs and have been Googling for days. Please help.

System

Mobo: Asus Striker II

OS: Windows Vista

HDD: WD Caviar Green Internal SATA 2 TB WCAVY1039971

History

Initially I had a very hard time getting vista to even recognize the drive (BIOs always saw it and it’s full size), I tried several programs to no effect and went from thread to thread trying different fixes. Ultimately, what worked for me was actually finding this post:

http://community.wdc.com/t5/forums/forumtopicpage/board-id/caviar/thread-id/32;jsessionid=2A8593E62EB69232830DF31D053B47F3 which lead me to this post:  http://seagate.custkb.com/seagate/crm/selfservice/search.jsp?DocId=211211&NewLang=en which basically tells you to go to here:  http://www.nvidia.com/Download/ScannForce.aspx?lang=en-usand upgrade your sata drivers. Also, for anyone who’s working on this, I had to go to this page several times and install several updates–it doesn’t do everything all in one.

So that took about two weeks and the end result is that when I go into disk management, Vista sees and recognizes that I have a formatted drive but it doesn’t have an assigned disk letter to it. I can assign one to it and it’s even recognized in “my computer”, but once I reboot, it’s gone.

Current Predicament

So, I’ve tried the following programs and haven’t been able to get the drive letter to stick:

* Vista’s Disk Management

* EASEUS Partition Master 4.1.1 Home Edition

* WinDLG

* Paragon Partition Manager (free version)

* Acronis True Image WD Edition

I’ve also tried creating several different sized partitions:

1 x 2tb

2 x 1tb

3 x 2/3TB

Any ideas?


#2

I think finally figured it out, over a month of digging, trying, failing, buying a new OS (Windows 7), nothing worked!

Breakthrough:

  1. Go to Computer Management

  2. Select Disc Managment

  3. Pick your abnormally large drive

  4. Delete any and all existing volumes on it by right clicking and selecting, “Delete Volume.”

It should now be entirely unallocated space

  1. Right click not on the long bar, but on the portion that says “Disk #”

  2. Convert to GPT (from MBR).


#3

First off, thx Anjuu2 for a pretty descriptive post, which led to me fixing the very same problem.

I wanted to add to his post due to my specs being quite different.

I am running an Asus Crossfire III which uses the ATI chipset and the drive in question is a 1 TB Samsung drive (I actually pulled it out of a Buffalo Network External casing and attached it straight to the mobo. *it was running way too slow via network)

My problem was the same, Windows (Vista) saw it in the computer management, however it would not assign it a drive letter. I could assign it one, but after the reboot, it was unassigned again.

So… I did as you suggested, (deleted the drive in computer management so it would show as unallocated space, however when I right clicked on the disk (not the bar, but the disk box) it only gave me properties, there was no convert to GPT.

****I do remember at one point way before I saw your post, the disk would show up in Computer management, but with a red arrow down, saying it was not initialized, so at that point I initialized it, but I set it as MBR. (which made the problem)

So… I used Samsung’s disk tool from their website, burn it to cd and booted it up, I went into lowlevel format menu, and at that point I could delete the MBR from it…

Rebooted…

Now I was then back at the point where my drive showed in computer management with the red arrow…

It was at this point that I had to intialize it…

(when I right click on the drive box) It gave me 2 options: 1 was set as MBR and 2 was set as GPT or GPI (something like that)  Option 2 states that this is a good option if you have an Itanium system or a drive OVER 2 TB. (Which I had neither)

But this time I chose option 2 anyways…

Rebooted

Now my drive shows everytime… (So far… :slight_smile:

I hope this helps any samsung users in the future and big props to Anjuu2  for getting me back on track…


#4

Had a similar situation:

Couln’t format the drive: The operation did not complete because the drive or partition is not enabled. To enable the partition or volume, restart the computer." However, restarting does not work.

After I got it formatted under Ubuntu (to NTFS) the drive letter did not stick. I could assign a drive letter but the drive still didn’t show up in My Computer and after a reboot the drive letter was gone again. 

Command prompt let me access the drive but Windows GUI said “The folder G:\ does not exist.” when typing G:\ to address bar. Also, when I typed “My Computer” to Internet Explorer’s address bar, I could see the drive and access it.

I suspect that either Daemon Tools or Dell Virtual CD drive had something to do with it. Either way:
Delete HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E967-E325-11CE-BFC1-08002BE10318}\UpperFilters key and reboot! After that Windows finds Generic Volume and asks for another reboot and all is good.