2TB External making funny noises, doesnt load, requires format

So, I bought a 2TB my book less than a week ago, and after copying pretty much my whole life to it, and it working fine, I plugged it in on my new PC (running windows 7 ultimate), which by the way it worked fine on for hours before, and it didnt work? Tried it a few times, still didnt work, so plugged it in on my laptop, and it just making whirring noises, and when I unlpugged it, it asked me to Format it.

Basically, I am pretty sure its knackered, after less than a week, and everything I ever had is on there now, I am so devestated.  I have got various recovery programs, but I when i plug it in I cant actually do anything, it just tries to find it, for ages, and all the programs just crash half way through scanning for it.

Has this happened to anyone else or is it just my bad luck?  Does anyone know what I can do?

Thanks in advance… :mansad:

Well in this case if no data recovery program helps, then you need to contact a professional data recovery company if you want to recover your files. :cry: