2TB Elements Drive suddenly acting very strange

Just bought this in May.  This weekend I moved my Mac Mini Server to a new location, along with the two Elements drives attached to it, each with two partitions.  When I powered everything back up one of the partitions wouldn’t appear on the desktop, and in Disk Utility was grayed out. Multiple attempts to access that partition failed, and any attempt to delete any partition on that drive, or erase the drive, would hang at “unmounting” until the process had to be killed.  Several “disk repair” attempts came back (after longer than usual) with no errors found.

After a short while neither partition would show up, and both were grey in Disk Utility.  This after removing the drive and moving it to another Mac for testing.

Eventually I attached it to a Linux machine and, using fdisk, was able to delete both partitions, though all operations seemed painfully slow compared to how I’m used to these drives behaving.

I moved the partitionless drive back to a Mac, and was able to create a single partition and format the drive. This was very, very slow.  I then tried (as a test) to copy a large chunk of data onto it, letting that run overnight.  In the morning it had failed with an error number–I forget which now but googling it seemed mostly associated with “drive busy” and people unable to empty trash.  Drive busy does seem in line with the drive failing to unmount so many times.

I then picked up a copy of Drive Genius LE and tried to run a scan of the drive.  In basic mode, no special operations, after 10 hours it was less than 1% done and said it would take over 47 days to finish. By comparison I started the same scan on the other drive and it would complete in 17 hours or less.  

So, what the heck is going on with this drive? Disk Utility never found any errors, after numerous checks. The drive formats without errors, it’s just insanely slow, as is anything I try to do with it. Is the drive going bad, or is it the controller circuitry attached to it, or what?  I can’t find anything remotely related to this behavior after days of googling. 

Any ideas?

Thanks in advance!

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


if I understand correctly, you deleted the partitions from the one drive on a linux machine.   Then you went to your mac and repartitioned and formatted the drive.  now everthing runs really slowly.  there could be a few issues to look at. one, not enough power.  plug the drive directly into a wall outlet to see if it improves performance.  two, bad cable.  use another cable to see if that fixes it.  three, you could have an elements drive that uses an advanced format drive.  I know some were released.  what version of mac are you using?  you need to make sure that it can align a 4k partition. finally, it’s possible that you corrupted the drive when you pulled the cables, and you may not have gotten rid of the corruption. you many want to do a write zeroes on the drive.

Thanks guys. What I ended up doing was (since WD doesn’t support anything other than Windows with its tools) fire up a Windows virtual machine on one of my Macs and ran the diagnostic tools. The drive is quite bad, and failed the test very quickly.  I’ve already shipped it back for a replacement since it was still under warranty.