2TB Drive - error messages about 'formatting' and Diagnostics Test errors

I have two WD MyBook External HDs hooked up to my Gateway Pentium 4 3.0 GHz PC - both a 2TB unit and a 1.5 unit.

Yesterday I started having trouble with the 2TB Unit (it’s 18 mo out of warranty) - it started INTERMITTANTLY giving me the following error message when I click on a ‘shortcut folder’ to it: ‘The disk in Drive G is not formatted. Would you like to format it now? Yes or No’

Despite this ‘error message’ - I can still get ‘limited access’ to all my data on the 2TB disk by clicking directly on the ‘shortcut icon’ for the drive itself and carefully pussyfooting/navigating around - and I am still able to get limited amounts of data copied OUT of the drive - however if I try to transfer any large files it will often self-abort and give me a error message saying ‘error reading from source’ and abort my operation. So I can get to my data and get small amounts out but it ain’t acting NORMAL at all and I am fearing for it’s life and all my TBs of Data

It seems like my drive is ‘acting sick’

In attempts to try to fix whatever it’s problem is I downloaded the “Data Lifeguard Diagnostics” program and took a look at some of the results - which I will attempt to convey:

 “Data Lifeguard Diagnostics”

1- SMART DATA RESULTS: Both my 2TB (the one that’s acting sick) and my 1.5 TB (which is working fine) drives have pretty close to the SAME profile on the ‘Smart Data’ - all the parameters for both seem to be within normal limits as far as I can understand. Apparently that may mean that neither drive is in imminent dire straits?

2- QUICK TEST RESULTS: However, both my 2TB (the one that’s acting sick) and my 1.5 TB drives (the one that’s acting normally) FAIL when I run the ‘Quick Test’.

They both gives the following message ‘Cable Test::Read Diagnostics Sector error!’

So the upshot is - any ideas **bleep** with my 2TB and is this is a self-fixable problem of some sort?

I changed all my cables around. I have no idea why I would be getting a ‘Cable Test::Read Diagnostics Sector error!’ for BOTH my ‘bad’ 2TB and my ‘good’ 1.5TB

Any suggestions for 1- what the problem is in ‘dummy language’ (me)  2- next steps or if a fix sounds like it might be possible

[PS: Not necessarily in need of specific answers - there are the  ‘secondary mysteries’ for me (if not cleared up by answers to the above) of why my ‘Smart Data’ results for both drives appear normal AND why both drives give me a ‘Quick Test’ results of a ‘Cable Test::Read Diagnostics Sector error!’]

Any help would be tremendously appreciated




As per your description the drive seems to be corrupted or about to fail. I’ll strongly suggest you to backup your data and then reformat the drive in order to make the unit fully operational again.