2 WD20EARS problem with RAID 1 mirror

Hi all,

I have a Windows 2008 R2 64 bit SP1 Server running with 2 WD20EARS-00MVWB0 drives in a mirror-set.

No problem so far.

1 drive became faulty, so I orderd a new WD20EARS drive.

When it arrived, I’ve noticed that it was a WD20EARS-07MVWB0 drive.

AFAIK the last part of the code is the firmware, so it should be much of a problem.

When I replaced the faulty drive and tried to remirror the drive, I got an error in Windows saying “All disks holding extents for a given volume must have the same sector size, and the sector size must be valid.”.

I’ve tried searching for any solution on the internet, removed patch 982018, didn’t find any firmware updates to download…

Can someone please help me with this problem?

The only thing to do is to find the correct drive since firmware updates for internal drives are not released to the public by WD.

1 Like

WD20EARS-00MVWB0 (i have two)

 reports having 512 physical and 512 logical hardware sectors.

WD20EARS-07MVWB0 ( http://communities.intel.com/thread/14422))

 reports having 4096 physical and 512 logical hardware sectors.

WD20EARS-00J2GB0 ( http://communities.intel.com/thread/14422))

 reports 512/512, the same as 00MVWB0

I am afraid that you will need either 00MVWB0 or 00J2GB0  (there are others, but i only have 00MVWB0, so

check what sector phy/log hw sector size will each drive report). I was really lucky, i brought the second +6 month

and got the same model…

The firmware version of my two WD20EARS-00MVWB0 are 50.0AB50 and 51.0AB51

1 Like