2 units passport wdbkxh5000abl = crash system

Have been given 2x WD Passport 500Gb wdbkxh5000abl-01 (gift)

we have 1x laptop (HP pavilion g6), 1x antique desktop (pentium D),

and 1x HP D530 CMT (DC577AV) - and ok, that’s old too, but still ticking along nicely.

The laptop loves the passports, the Pentium D finds them tricky, always wanting to install the drivers, but once that is cancelled works with them, albeit extremely slow, treating them as USB 1.0,

however (aka “but”) the D530 hates them. when you plug them into any USB port the system fans go into over-drive and the system locks up, requiring a hard reboot.

There are 10 USB 2.0 ports, 2 front case, 4 mainboard and 4 on a plugin card, all elicit the same response,

One front port is problematic so I have a blank in it, and one of the ports on the plug-in is internal so we dont use that either.

I have tried removing every other USB device (except the mouse) - the passports still crash the system.

Typically the system has a USB wireless mouse and 2x self powered external USB HDD’s (a Maxtor 2Tb) and (a 3TB Western Digital (WDBAAU0030HBK-01)), that is usually all connected,

sometimes the system may also have up to 5 other USB portable (2.5") drives at any one time, being a mix of WD Element drives (500-750GB), Astone’s (with 500GB WD drives in them) and a number of older drives in generic cases (varying from 40Gb to 250GB) - these all run with No Problems…

As far as I can tell no type of drive letter software is installed, although in the dark distant pass a CD emulator was installed (a daemon variant as I recall) and that left 3 “echo” drives behind when uninstalled - have trawled the net and tried everything to remove the echoes, gave up on that last year…

Why do the passports crash the D530?

thank you,


Since the drives are working fine on your other computers it means the issue you are having is with your HP D530 CMT and not the drive itself.

Based on your description of the issue, it is possible that your are having a conflict between the “echoes” that you are mentioning and the virtual CD included on the drive.

I can also recommend that you try going to disk management and deleting the drive letter to these “echoes”  to verify if the drive will function properly. Otherwise If you cannot find a solution to remove this “echoes” then you will have to reinstall the operating system.

No Joy, (managed to erase the emulation ghosts)

it seems i cannot have both types of WD drives plugged into the computer at the same time,

one or the other, but not both.

(Passport 500Gb wdbkxh5000abl-01) or (3TB Western Digital (WDBAAU0030HBK-01)



I still have not resolved the second part of this problem, the system lockup if both drives are present and open in explorer,

I can have either drive type plugged in, but if I have an explorer window open on that drive, then, when I connect the other type and explorer tries to read it, then the system locks up.

Is there a driver I need to replace or delete, a system setting to change?

(this problem defeats the whole purpose of having the portable drives in the first place.)

Thank you



Just for testing purposes, can you please try them both on another computer?

Connect one drive and make sure it is working by copying a file into it, then connect the second drive and try to copy a file to it as well.