2 TB WD External Drive Connection Problem


#1

I tried to update the firmware for my 2TB My Book Essential drive a few hours ago.  After the update, it told me to restart my computer and turn off the drive.  Then turn the drive back on after my computer is ready.  I tried doing that and since I tried the firmware update, my drive does NOT connect to my computer.  I have tried restarting my computer and the drive 5 times already and I have also tried reconnecting the drive.  Nothing has worked so far and the problem still persists.  I used to use this drive as the backup drive for my PC with Windows 7 64-bit.  I just bought a MacBook Pro a few days ago and I have reformatted the drive to work with my MacBook Pro.  I have installed the WD Smartware on my new Mac, but it is now unable to detect the drive when I plug it in.  The Mac OS X cannot detect it either or the Smartware software located on the drive.  However, like I said previously, I have formatted the partition to work with a Mac.  Does anyone have any suggestions on what else I can try to get my drive working again?  I have some data files on there that I cannot lose!  Thanks.


#2

If you did the firmware update on your Mac I would try doing the firmware update again on your PC. However, it looks like the drive may be damaged and needs to be replaced. Looks like something happened during the firmware update and it wasn’t fully applied to the drive.