2 TB MyBook shows as a CD ROM on my Wndows 10 computer

This mybook drive is not able to be accessed from a PC. Have tried 3 Windows PC’s multiple USB 2 and 3 ports. In this Computer it shows as a CDROM sometimes and sometimes it doesn’t appear at all. When I view the drive in Disk Management it shows as an unknown partition and says not initialized. There is also a red ICON with a white down arrow to the left of the disk #. I tried to in initialize it as both MBR and GUID and it fails. I have also used “Diskpart” . It recognizes the drive # and allows me to select the disk # corresponding to the drive. I can “Clean” the drive successfully but it fails (times out) when I try to create a primary Partition. The drive in the enclosure is a WD Green 2.0 TB Drive. The external drive has never been used. I have removed the drive from the enclosure and when I connect it natively through a USB disk drive dock, I have the same issue. How can I fix this???

Thanks for any assistance
Mal Leichter

Hi @mleichter,

Please refer to the following article to troubleshoot the drive:

I tried to to to this link but get a message: “This site can’t be reached”


Please refer article of My Cloud OS 5: Dashboard HTTPS Access “This site can’t be reached” Message:

For more information, please contact the WD Technical Support team for best assistance and troubleshooting: