2 TB MyBook Essentials Issues

Hello! I have had by 2TB MyBook Essential since 2012. It has worked great and I still have 1.92 TB of storage on it. I don’t use it often but keep it stored in it’s original box, upright, and cover it so dust does not get inside.

I recently updated my mac with Sierra. It was my first system update since I bought the computer (also in 2012).

Recently when I went to move files over into my MyBook… I plugged it in, I could access and read ALL of the files that I had previously saved to my hard drive but I could not add any more files.

When I first plugged it in to the computer it did ask if I wanted to back up my entire computer on to the macbook and I said no, because when I clicked yes, it said that it would erase the previous backup on the HD, and I was afraid it would erase the files I currently have stored. SO I cancelled it and clicked “no” the next time I was given the same prompt.

I then tried to drag a folder from my desktop into the Hard Drive, which have often done in the past with no problem. This time, however, it doesn’t allow it.

How do I fix this so I am able to save more files. I still have tons of space on this HD.


See if the following link helps to solve the read only drive.