2 MyClouds not showing up on "Network" in windows file manager

#10

My guess is that it is related to the master browser table somehow.

Basically, SMB protocol elects a “master browser” from the list of available servers, and that server supplies the list of network resource supplying servers. When the “network” is queried, it is really asking these questions on the wire:

[client–broadcast] Who is the master browser?
[master browser–broadcast] I am!
[client-- to master browser] Give me a list of resources in this workgroup.
[masterbrowser-- to client] This is my list.

I have noticed that there can be issues getting windows hosts to stop being the master browser/get windows hosts to accept a master browser that is not a windows server host— and in this circumstance, getting the windows host master browser to accept SAMBA hosts as service hosting devices.

I dont really want to call malfeasance on microsoft over it, but I haven’t been able to properly enroll a netbios named SAMBA client since windows XP.

I always just static IP the devices, and connect to them by IP address.

#11

@Frozen1 Yes, on my new Desktop that I have had for two weeks. On my laptop the My Cloud and all my other devices recognized as a computer show up.

I have tried a lot of things but so far nothing has worked.

#12

The odd thing to me is every other device on my network shows up without any issues. It is only the WD MyClouds that are not showing up. I just got a new router, and have not set it up yet, but maybe that will change things.

This is not a real big deal to my, but for my wife who is not as comfortable typing in network addresses, this is painful.

#13

Obvious things to check if you have already ensured each My Cloud device has a unique device name and IP address. Start by reserving an IP address for each My Cloud device within the router if possible. Ensure each My Cloud is using the correct Workgroup name as all other computers/devices on the local network. Ensure the problematic computer is NOT connected to a guest wireless network that may be restricted from accessing the rest of the wired local network. Ensure the problematic computer’s security software or firewall software isn’t blocking access to local network devices. If using Windows, ensure NetBIOS over TCP/IP is enabled and one is using Private Network as the group network setting.

#14

I have been over this many times… nothing changed in the network, one day they just were not there. And obviously I am not the only one seeing this as others have jumped.

#15

Just because you assume nothing changed on the local network (or with your computer’s OS) doesn’t mean something hasn’t changed. Obviously something has changed. Point is, one should review the standard troubleshooting things/steps that may affect the inability of the computer to see the My Cloud on the local network.

It’s possible a Windows update (if using Windows) may have changed something within the OS. Wouldn’t be the first time a Microsoft update affected access to the NAS devices like the My Cloud using SMB. A software update for third party firewalls could have changed or reset the firewall settings. A network driver update may even affect the network port on the computer causing problems. An ISP router or third party consumer router firmware update may affect router settings causing local network DNS issues.

It may sound repetitive and stupid but many of the troubleshooting suggestions in the following post, including Windows 10 Specific Method 1 through Windows 10 Specific Method 5 often solve general access problems with the My Cloud.

Windows 7 has similar settings that should be checked. Another basic troubleshooting step is to power down all network devices. Power on the network router and wait for it to finish booting up. Then power on the My Cloud and wait for it to display a blue front LED. Then power one one single computer (that was exhibiting the access issue) and after it boots into Windows see if the access issue continues. If not then continue turning on other network devices, checking after each device finishes booting up is the issue persists with that device.

#16

@Frozen1

Try the following and see if it works for you, I just created a topic for this.

#17

SMB 1.0 has many outstanding security vulns!!

https://blogs.technet.microsoft.com/filecab/2016/09/16/stop-using-smb1/

It is best never enabled! Dont turn it on! :rage:

#18

Some may, for what ever reason, have no choice but to enable it in order to get the My Cloud to show up in Windows 10. Microsoft changed things with the Windows 10 Fall Creators Update and SMB1 is not installed by default with that update.

#19

The bigger question is why is WD using such and old protocol?

This does work BTW…

#20

As a test I removed the check for SMB 1.0/CIFS File Sharing Support on a Windows 10 PC (with the latest updates) and sure enough the My Cloud is no longer seen in Windows File Explorer as a file server. I have to manually enter the name in the address bar area (ex: \\wdmycloud) for the My Cloud to show up as a file server. Windows File Explorer does see the media server though so it’s obviously a problem, I assume, with SMB either on the My Cloud or the Windows 10 PC or possibly with the local network router (ISP provided) not properly resolving network clients.

#21

WD Knowledgebase article that are relevant to the missing My Cloud when using Windows 10 Fall Creator version. Their suggestions are to either enable SMB 1.0/CIFS File Sharing Support, or select the My Cloud icon under Storage (in Windows File Explorer) and select Open from the list of choices.

#22

As others have written about in other topics and on my new desktop computer with latest Windows 10 updates the choice to open no longer appears.

image

One can pin a shortcut to start, see this prior post/topic.

#23

There seems to be two issues going on here. One is the problem with the My Cloud when the SMB 1.0/CIFS File Sharing Support is disabled. As several posts/links have indicated it is wise (but not optimal) to disable SMB 1.0/CIFS File Sharing Support due to the various security vulnerabilities present in it. Obviously there is something wrong within the Samba used on the My Cloud that causes the My Cloud to not show up when SMB 1.0/CIFS File Sharing Support is disabled. That is something WD (one would hope) will have to address going forward as more and more PC’s with Windows Fall Creator Update will not see the My Cloud.

The other issue with Microsoft Windows and the possible removal of the Open option when selecting on the My Cloud icon under Storage. I assume those who’s computers came with the Windows 10 Fall Creators version are the one’s having the bulk of the problems with both of these issues.

My earlier version of Windows 10 that has been updated with the Fall Creators update (version 1709 - OS Build 16299.125) on both of my main PC’s does have the Open option for the My Cloud icon under Storage. In fact the My Cloud icon looks different than yours. Wonder if that is the cause of the missing Open option.

MyCloudStorage

For example the Roku icon is similar to your My Cloud storage icon and it too does not have the Open option (nor should it). As such it would appear your Windows is potentially misidentifying the My Cloud for some reason. Strange.

RokuOtherDevice

#24

I am reading—

Microsoft has depreciated the “Master browser/announce” method (which was used in SMB1.0), and now uses a different technology, ‘Web Services Discovery protocol’ (WS-Discovery), to populate network neighborhood for local devices. I dont see that Samba supports this protocol, which seems to be the root of the problem.

Computer Browser service depends on SMB1.0 being turned on, which is why turning it on suddenly makes it work again. MS disabled it for important reasons, and is pushing an alternative protocol. One Samba does not (yet) seem to support.

I am still looking for any documentation on this new protocol in Samba, but coming up empty so far.

#25

I experienced the exact same problem. Microsoft disabled (by default) SMB1.0 as part of one of the recent updates (past 3 to 6 months). It’s too bad WD is still dependent an antiquated and susceptible (to ransomware) protocol like SMB. All over the Internet, Microsoft and security experts are adamant … disable SMB1.0.

So with that said, now we are stuck with not being able to see the WD NAS through explorer in a Windows workgroup. Oh sure you can map a drive … I don’t want to map a drive and someone (I think WD) said just right click and “Open” the WD device under Storage devices, but here is a tip to the WD staff that suggested that, if you are inside an application where you need to navigate to a file source (like adding an attachment in an email), Storage Devices Don’t Show Up!

So we are back to needing the WD NAS to appear as a computer, like it has for years, on a Windows workgroup network, not a domain, a workgroup since that is what the vast majority of home users and small businesses still use today.

#26

To be fair, ANY linux based NAS (which is basically all??) is going to have this problem, since the issue is the depreciation of the Browse-Announce framework, and the adoption of the Web Services-Announce framework. There is no web-services announce daemon for fileshares on linux that I can find, but there is one for digital security cameras. Possibly it can be adapted to also report about SMB shares, so that windows hosts can get properly informed that the shares are available.

The impetus at the moment is in the linux community’s court, as there is a need not being met there.

#27

No you are NOT stuck with not being able to access the My Cloud through Windows Explorer. Even though is it suggested one not use SMB1.0 one can still enable it, or re-enable it if they want to through the Turn Windows Features On Off section.

This isn’t the first time a change by Microsoft caused problems with the My Cloud. Like the previous poster indicated this issue is present with other NAS devices not just the My Cloud. One can still access the My Cloud using the device’s IP address. One can still map Shares. And one can turn SMB1 back on if they so desire.

#28

Yea I AM stuck because I lost a specific type of functionality I use and desire, and before you jump on the WD fanboy wagon, I know the weakness in SMB1.0 is a Microsoft issue … duh.

Oh my gosh, I NEVER thought of reactivating SMB1.0, holy cow, this is the most amazing thing in the whole wide world, my oh my, complete hysteria will certainly follow, human sacrifices, cats and dog living together, UREKA … I can reactivate SMB1.0. … how could I have missed that … how could I have been so stupid … I am so disheartened … wait a minute … I just realized something … I already knew that … yea that’s the ticket … let me think for a second … humm let’s see … I’m not a moron and I am smart enough to follow the strong recommendations of Microsoft and virtually the entire computing community that says … Disable SMB1.0, its dangerous!!!

Let me ponder a bit longer … well, I also know all about mapping drives, which I already said I don’t want to do, so don’t throw that in my face like it’s some new discovery you are trying to educate me with. I know all about using the IP address, oh and here is one for you I can \\MYCLOUD too, so I know about all these other ways to access the NAS, but thanks for telling me what I already know.

#29

Why not?

It is by far the best way of accessing a NAS. You do it once, and they will reconnect every time your PC reboots. And can be used in exactly the same way as any local disk on your PC.