2 MyCloud 6TB drives, one has a red led. What do i do?

I have a MyCloud 6TB NAS drive. One has a red led. I don’t think it flashes. Sometimes it’s blue or white after I turn it on after a while before turning red. No matter what color, I can access my files, but after a while when red, the connection eventually slows, and sometimes times out, later, I can access my files for a while again.

I have another NAS by Seagate, I switched the data-full HD from another with the same model, and works fine now.

I contacted WD a while ago, I think they said I can reformat the HD and it will be fine again. But I have allot of data and I don’t think I can just move the files. If I do, I’m afraid of it completely dying, or just a long week of dangerous file transfers.

I have a second MyCloud 6TB NAS drive now. Is there a way of swapping the full HD with the empty?



I have no replies but 60 views so I hope someone will speak up soon. Anyway, I’m coping file from my old mycloud to the new one. Due to the error/red led, I’ve had to use Ext2 Volume Manager for windows to recognize the linux partition. The problem is, it takes forever to move folders with content. I tried to copy the files in dos, but I don’t know the command. I’ve used ‘copy’, ‘xcopy’, and ‘robocopy.’ But it won’t copy. After a quick check, I realized that I can’t access the destination (new mycould) in dos. It’s a network location with an ip address. I created a map letter so I don’t need to deal with the ip address of the new mycloud. But I still can’t access the new mycloud in dos. The error is, “The system cannot find the drive specified.”

Does anyone who the exact command to copy the files from the old mycloud to the new which is a network location?

Red LED means a fault… Could be a poor network connection; have you tried a different cable & router port?

Could be overheating; are the vents clear? Have you checked the Dashboard for alerts? Have you checked the device status with the Dashboard, or run the diagnostics?

If you think your original HDD is dying, why do you want to move it to the new device?

If both MyCloud devices are the same generation (running both running either v4 or v2 firmware), then, yes, you should be able to put the old disk in the new drive, if you suspect the control board has some failure. It will void your warranty, of course.

Since you mention needing a ext2 file manager, I assume you have already taken the disk out of the first drive. In which case, see this thread:

Yes, it will take time. But your computer will do it for you; just leave it alone to get on with it. It will be preferable if you have a gigabit network.