2.5TB drive shows only 300mb capacity when formatted

I just formatted a brand new WD25EZRX “Caviar Green” 2.5TB drive with Mac OS 10.6.8 and the drive capacity shows only 300 MB available. I tried to set up a larger partition with GUID using Disk Utility  but it didn’t work. I am using this as an external drive in a Firewire 800 enclosure. Any suggestions appreciated.

I don’t know about Macs but in Windows drives bigger than 2 TB need to be formatted with GPT instead of MRB. Is this a WD USB drive?


Thanks for the reply Joe. It’s a SATA drive inside an enclosure that has Firewire 800, USB2 and eSATA. I’m using the FW800 port. This is on a Mac running OS 10.6.8.

i have recently purchased a few 3.0 TB WD Caviar Green SATA drives and after formatting they only show 800.79GB available. I have tried on a few different Intel Macs running 10.6.8 but repeatedly have the same problem.  Have you found anything yet?

Maybe this drive needs advanced formatting try looking here and see if you can figure it out http://www.wdc.com/en/products/products.aspx?id=120 You"ll have to click on the advanced format tab. Findng stuff on their site isn’t always that easy.


Thanks again for your reply Joe, and ddscott57, there is hope! I phoned WD’s tech support and they told me to try two things: 1) format the drive as an internal in a Mac Pro and 2) if that doesn’t work, format it with zeroes as an internal drive in a Windows machine. I took the drives into the office, popped them in my Mac Pro and they formatted to capacity.

One interesting anomaly: I started using one of the drives immediately as an internal drive in the Mac Pro. The other two were not used. The Mac Pro crashed and, after restart, the two unused drives once again show a smaller capacity.  I’ll format them again, this time with zeroes, or put some data on them immediately after formatting, and I suspect they will retain their larger capacities.

The real problem for me was in the enclosures. After reformatting the drives internally, I tried them in the Nexstar enclosures I use, and they once again showed a smaller capacity. I guess the chips in the enclosures can only address up to 2tb. Next time I was at my friendly computer store, I started reading the fine print on the enclosure packaging and, sure enough, a number of them are starting to post warnings that their enclosures only work on drives up to 2 tb. So look for an enclosure that says it can handle drives of the size you need.

In Windows drives larger than 2 T need to be formatted GPT instead of MRB. You might also try using the WD formatter it’s in downloads.