2.5" SATA to R Pi adapter board

I received a 2.5" SATA to R Pi adapter board today. I have not found any documentation on it, so I began experimenting with it.

I have verified that my Compute Module is working with the R Pi board that came in the kit when I bought the Compute Module.

I tried using my Adapter board + Compute Module with a SATA drive, a USB to a powered hub, and using an HDMI display. No luck. Tried pressing the on/off button several times, no luck.

I tried using my Adapter board + Compute Module with no SATA drive, no USB device, and using an HDMI display. No luck. Tried pressing the on/off button several times, no luck.

I removed the Compute Module, no SATA drive, no USB device. I powered on, then press the on/off button. I then see a blue LED on steady. This is the only indication of anything that I have seen.

Any ideas? Any documentation that goes with this Adapter board?


Hello Peter_Appleby! :slight_smile:

Let me try and help with your situation. :slight_smile:

You will need to first program the RPi Compute Module whenever you are using it with either of the two WD Labs products: the Media Stick for RPi or the SATA-to-Raspberry Pi Adapter. In your case, it is the latter.

This link to a post from a fellow staff member will help you understand the steps needed to take:

Basically, install the compute module into the adapter board without connecting anything to the USB ports, connect the USB Micro B port to the host computer without pressing the power button and flash the RPi Compute Module eMMC. Safely eject, disconnect from power, wait 20 seconds, reconnect your peripherals and you should be ready to go!

For the full and detailed instructions, please first visit the link above, in order for your device to start working properly. :slight_smile:

Good luck! :blush:


Just a quick clarification. My R Pi compute module has already been programmed using the board that came with the compute module. I still need to reprogram the board using the WD adapter board? Not sure I understand why but I will try it.


Yes, please reprogram the RPi Compute Module with the SATA-to-Raspberry Pi Adapter for the specific situation when they are used together. Update us afterwards. :slight_smile:



Still can not use this board. Where is there some real documentation for this?

What does the blue LED indicate? The only time I have seen it is when I tried to remove the Compute Module.

The board is not detected when I try to program the Compute Module. No LED.

This is really weak. Is anyone out there having any success?

Hi again!

We would require some more details in order to better troubleshoot your problem. Please provide information/answers on the following:

send a photo of your set up;
how much power is it being provided;
what kind of 5v power adapter type are you using, and type and length of the cables;
does the compute module still work if you plug it back into the RPi compute module development board?

Every detail/photo you’d provide would give us additional information on your situation; the cables, the type of SATA drive, if the Compute Module is plugged into the board correctly, etc. The best you could do to provide help at this point is to make a short video of the set up with you pushing the power button.

Thanks! Post back! :slight_smile:


I’ve been trying for the past 3 days to get my Compute Module 3 flashed. I’ve tried 4 different chords to connect with the PC. I’ve tried everything thats been stated in this community and using google search.

I run RPIBoot as administrator, Screen stays on the “Waiting for BCM2835/6/7”

The PC is able to find the device as “WD My Book 25A7 USB Device”, however, it will not find the CM3.

Is there anything else I need to do to get this to work?

Were you following the flashing instructions at Compute Module Programming Instructions ?