1TB WD My Passport

Hi! I’ve been using my storage device for almost 3 years and suddenly one day i plug it in and it doesnt show up in my computer. i also checked in disk management in my computer and it shows “unallocated files” and when i try to initialize it says media is write protected. finally ive tried to run the data lifegurad diagnostics and it shows to many bad sectors detected. what will i do now to retrieve my files? please help me… thanks!!


Check online for a data recovery software. Some of the data recovery software, are able to look for the files through the sectors.

Also please see the link below for more information on how to get the files out of the drive.


I have the same problem. Its not even a Year I purchased it :frowning:

Its not working now from last 2 days and I am in a deadly situation where all my important project related information is stored in the device.

I have also logged a case in your customer portal. Please, I need an urgent help on this.


Hi Help4all, thanks for the info, i’ve tried some of data recovery software online ive also waited almost 8 hours of scaning but the scan was empty and i couldnt find any solution to my files in my HDD. what will i do now? i badly needed those files…:confounded:

I’m very new here.   Just wanted to say I recovered some files from our vacation I had backed up on a Seagate external hard drive a week ago using Recuva latest version - free download.  Piles and folders were showing up but would not transfer to my pc or another external drive.  Hope this helps.

hi i just found out that u need password in order to open or recover data from my HDD sadly in my case i forgot it but good news coz i had a backup in my pc so i just erased it and put it all again, now ive learn that its important to have always backup files. thanks anyway and have a nice day!

your drive wont be empty it just shows that because its write protected. this is a common problem with a 2.5 1tb smartwave drive that WD released. i have the same problem. still no fix.

only way to unlock is via VCD/Smartwave and if the VCD link to drive unlock via smartwave is removed you cant unlock even if you know the password. use 3rd party software or use different os or par soft. its stupid. i have tried every recovery software know to man