1TB USB 3.0 Very Slow ( Model: WDBBEP0010BBK-NESN)

I have this HD for about 6 months and everything was fine until today.

I tried to copy a 11gb file to it, but the transfer froze, then my PC froze afterwards. Tried to transfer it again and the same thing happened. Both times i had to reset the PC.

I use windows 7 64-bits.

Since then, the HD is really slow. It takes like 15 seconds just to see the files in a video folder, transfer rates slow (40kb/s) and i’m not sure if it’s transfering. It even lags if i try to watch a video thats on it.

Apparently i can’t backup the files on it, it will take forever.

It takes a while to mount and to unmount. Can’t mount it on my TV anymore.

Can you guys help me out? Any programs i should use to bring it back to normal life without formating?

Will format help?

Thanks in advance.

Try running a test with DLG.


I tried to use the DLG, but i can only run the test on the Physical Drives from the top window. My WD External Drive is on a USB port and is listed in the botton window as the F drive.

How can i run the DLG on my WD External Drive?

Bump, can someone else help me out please?

Two weeks and i still got no help :frowning:

The information inside the Passport is probably corrupted. Try using a data recovery program like Recuva. If that doesn’t help it is most likely faulty.

Thanks for the reply.

I don’t think it’s the data. Because i formated it, but it didn’t help. It’s still very slow.

Is there anything i can do to try to reset the hard drive other then format? Like a firmware update or something.

I used disk fragmentation but it didn’t help either.


Can someone help me out pleaes?

Is there anything else to do to “reset” the HD after formatting?

And how should i proceed with RMA if it’s faulty? I got it on amazon when i was at the US, but i live in another country.