1TB MyPassport troubleshooting (assistance needed)

My Parent’s 1TB Passport is no longer being seen by their computer. We have done the following troubleshooting:

  • Tried 3 different cables
  • Tried 3 different computers
  • Tried various combinations of computers and cables
  • Problem appears to be with the drive
  • The Drive itself is getting power (LED light is also active in a solid on state, no flashing after initial connection to the system)
  • The drive does spin up. but stops spinning after about 30 seconds. I assume this is normal as the drive is not being accessed by the system.
  • Any computer - Detects the connection of the drive, installs default windows drivers (Generic) to access the drive.
  • However, drive does not show up in My computer or Computer management console.

The drive itself is just out of warranty by about 1 month (End date 11/27/2012) so at this time i am looking into any options to repair the drive or understand whats happened.

As i am sure is always the story, the data on the drive was not backed up to a secondary location so we are also trying to find a low cost way to recover any data we can.

Following a previous post I found by fzabkar I downloaded and ran Microsofts USB device viewer to see if the drive is even talking to the system.

I did find 3 devices connected to the USB controler

  1. Mouse
  2. Keyboard
  3. Initio Default Controller (Same name that shows up when I plug in the drive)

I am not nearly as technical as I use to be 5 years ago but the device information has a few things that seem…“not good” though i dont know if or how they can be fixed if they are truly the problem

I have marked in red the areas that seem problematic and do not show up when compared to a 2nd USB hard drive in in the device viewer .

I hope this is more info than the typical “help me post” so looking for any assistance i can get.

Thanks!!!

--------------The Device information-------------

—===>Device Information<===—

ConnectionStatus:
Current Config Value: 0x01 -> Device Bus Speed: High
Device Address: 0x03
Open Pipes: 0
*!*ERROR: No open pipes!

===>Device Descriptor<===
bLength: 0x12
bDescriptorType: 0x01
bcdUSB: 0x0200
bDeviceClass: 0xFF -> This is a Vendor Specific Device
bDeviceSubClass: 0xFF
bDeviceProtocol: 0xFF
bMaxPacketSize0: 0x40 = (64) Bytes
idVendor: 0x13FDidProduct: 0x1617
bcdDevice: 0x0100
iManufacturer: 0x00
iProduct: 0x00
iSerialNumber: 0x00
bNumConfigurations: 0x01

===>Configuration Descriptor<===
bLength: 0x09
bDescriptorType: 0x02
wTotalLength: 0x0012 -> Validated
bNumInterfaces: 0x01
bConfigurationValue: 0x01
iConfiguration: 0x00
bmAttributes: 0xC0 -> Bus Powered
MaxPower: 0x01 = 2 mA

===>Interface Descriptor<===
bLength: 0x09
bDescriptorType: 0x04
bInterfaceNumber: 0x00
bAlternateSetting: 0x00
bNumEndpoints: 0x00
bInterfaceClass: 0xFF -> Vendor Specific Device
bInterfaceSubClass: 0xFF
*!CAUTION: This appears to be an invalid bInterfaceSubClass
bInterfaceProtocol: 0xFF
!WARNING: must be set to PC_PROTOCOL_UNDEFINED 0 for this class
iInterface: 0x00
!*ERROR: 0xFF is the prerelease USB Video Class ID

 

 

Not sure what all those mean but ERROR WARNING and CAUTION are generally not a great thing to see.

 

 

Usually when the Initio Default Controler is showing there is a problem on the circuit board. Try sending fzabkar a PM he knows the most about the boards.

Joe

Thanks Joe, I sent him a PM as recomended, do you or anyone happen to know if this circut  board is in fact “dead” is it replaceable similar to those of standard SATA drives? I had a board die on me in my PC years ago and i simply found one on ebay that matched, pulled the board and placed it on my old drive…thing is still workign to this day =D hoping these USB ones are similar.

The short answer is that I don’t think I can help you. Sorry.

Regarding the PCB, depending on which model you have, there could either be a separate USB-SATA bridge board, or the USB-SATA bridge IC could be incorporated on the drive itself. A further complication is that certain models (eg Essentials) are hardware encrypted, even if you have not set a password. If you are replacing the HDD PCB, then you will need to transfer the serial flash memory IC, or its contents, at location U12 from patient to donor. If U12 is vacant, then the unique, drive specific “adaptive” data will be internal to the Marvell MCU (the largest IC). If the drive is encrypted, then you may need to transfer a second 8-pin chip. This second IC contains the firmware for the bridge IC.

As for the “Initio Default Controller”, there are several possible reasons why the external mass storage device identifies itself in this way. On the bridge board there will be an Initio INIC-1607E or INIC-1607P bridge IC. Your PC (USB host) speaks USB while the drive (USB peripheral) talks SATA. The bridge IC is their interpreter. When it powers up, the bridge IC attempts to locate an external EEPROM. This EEPROM will contain WD’s OEM firmware. It also stores the identity of WD’s product, ie WD’s USB Vendor ID and Product ID, product name (“Passport”), serial number, power requirement in milliamps, etc. If the EEPROM is absent or corrupt (bad checksum), then the bridge IC will revert to identifying itself with Initio Corp’s Vendor ID (0x13FD) and Product ID (0x1617). This is what happens at manufacturing time when the EEPROM is blank. In this case the bridge IC prepares itself to receive a firmware download. In fact you may have seen cases where users have reported that their Passports or My Books have become “Initio Default Controllers” after a failed firmware update.

In Seagate’s case, users typically report that their drives identify as “Initio Default Controllers” if insufficient power is available from the USB port. The remedy in most cases is a USB Y-cable that picks up power from two USB ports. Obviously this is not the problem in your case.

Another reason that your Passport may identify as an Initio Default Controller is if the firmware is programmed to report Initio’s ID whenever WD’s HDD cannot be detected. Some bridge firmware will not enumerate itself at all if a drive doesn’t come ready, while other firmware may identify the bridge IC instead. In fact I have seen some reference designs for bridge circuits where a jumper can be used to define one or the other behaviour. Therefore it could be that your drive is spinning up but not coming ready. That would appear to explain the symptoms in Seagate’s case.