1tb My Book with a loose usb port


#1

Recently, my hard drive has stopped turning on. Checking into the matter i noticed that the usb port on the hard drive was loose, as the cord could move left and right pretty easily. I was just wondering if its possible to fix this myself, seeing as how it seems to be a pretty minor problem. I’d like to avoid going to a repair shop to fix this cause im sure they’ll overcharge me for it.

Is this a quick fixer upper?

Can i open the drive easily to fix the problem?


#2

Hey man, same problem.

Did you end up fixing it ?

If so, would love to know how.

Kind regards

J-Baby


#3

I have a similar problem with 500 GB and 1TB.  The female part of my mini USB port was too big for the male plug of all the mini USB cable that I have tried, including the one that came with the drive! Thereby this connection was always loose and the weight of the cable hanging down was enough to make each HDD unrecognizable to my PC. My solution was to treduce the weight of the cable by fastening the cable with velcro to the side of the drive box, in a loop fashion, thereby taking the pull of the connection. So far it’s been working fine for the three that I have it connected this way.


#4

This problem has been plaguing me for quite some time, and it’s really troublesome to have to place the drive in a very distinct position just in order to get it to run.  Is there any actual fix for it?  I really shouldn’t have to ghetto rig a problem in order to get it to work correctly…


#5

 Based on my experuence with WD,  I think to refuse to accept /acknowledge that the problem exists. Also in my thinking of  “ghetto rig” solutions to this problem, in lieu any meaningful help from WD, in my humble opinion the basic problem is the mini USB Port  in the drive is too far into (recessed) the case, either by design or feeble manufacturing.  The amount of  this recess doesn’t  “allow” male metal part of the cable to seat firmly in the port, hence even a sneeze can dislodge the connection. Although my fix is definitely  “ghetto rig”  repair it solves the problem for at least  temporarily, until WD takes the problem to heart as being real and stop replacing these flawed units with equally flawed units as they did in my case with different drives of mine. When I connected the replacement units, I quickly learned the replacements were as messed as my originals, so I stopped trying to get WD to understand the problem, because it was obvious to me that no one bothered to look at these units, let alone plug a mini USB cable into the port to see how firm the connection really was.  Interestingly enough, I bought my wife a WD Passport Essentials Ext, HDD. And though her HDD had the same type of connection (mini USB), the port located the right distance from the case so the cable connection was firm and tight!!


#6

I had the same problem with both my 500GB and 1 TB My Book drives.  Since both these drives also have an eSATA port; I bought two eSATA to USB adapters along with the appropiate length USB extension cable. This alternate connection worked just fine.  I tried your approach i.e… fixing the internal port. but found out that the mini USB port is recessed to far into the case repaired wuithout major effort. My fix costed about $15 per drive and it works just fine.  I really think that WD won’t admit to the fault but I am sure t5hat if enough people **bleep** at them, especially users whose drives are still under warranty who demand a replacement drive possibly upgrade to a MyBook 3.


#7

Well it finally happened; WD capitulated after my consistent ragging at them for my problems with their faulty Mini USB ports in both my WD 500GB  & 1TB My Book Studio Edition drives.  After this most recent “go around” they finally replaced both my faulty drives with MY Book Home editions.  I already have them here and as soon as I get the data copied from faulty drives to the new ones, I’ll Mini port is nearer the outside of the case then my faulty drives, so the problem has been addressed by WD at least in this MyBook Home edition.  I appreciate the help of the WD supervisor who finally took over my case from the WD Tech Support guy who I told that his solution was not acceptable to me!!!